Installing SanDisk SecureAccess from iXpand 32GB

Just purchased this new product. When following the instructions to install SecureAccess from the flash drive (to a Windows 8.1 computer), I was told that an update is available. However, when I clicked “Update” a message displayed saying that the update failed because the location ( could not be found. I tried several times, all with the same result. I even tried typing the download URL directly into my browser. That, too, failed. Subsequently, I had to browse around the SanDisk Web site in order to find information about the software, and a place from which I could download it. It would appear that the SanDisk folks failed to test and validate the .exe file that they loaded on the drive before releasing it to market. Shame, shame.

:smiley:   Hi Kram,

Dear member of SanDisk Community, welcome.

Friend, sorry.

Please, “clean up” your UFD (erase the content), and start again with the following:

See link:

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                            (Google translated)


Hope you were able to resolve your problem installing upgrade.  My experience with the same iXpand 32G was different:

iXpand came loaded with installation of SanDisk SecureAcces v3(call it SDSA).  I installed it.  At the bottom right was a button for upgrade, which I clicked.  It offered the upgrade for $12.  I went ahead.  It then allowed download of the upgrade software. It looks quite similar but it is called  Encryptstick  v6.(offers higher encryption). I see no other difference from the Non-Upgraded software.     Now I have two softwares to look at the files in my iXpand:  SanDsk SA v3 and Encryptstick.

I have not yet found a reliable way to place load files and then find them with Encrypstick so I am using mosty the SDSA v3., so up to now I consider the $12 upgrade a total loss of money and more importantly: TIME.

However, there have been times when it would not see the files on the iXpand with SDSA and then  Encrypstick would see files.  I still cannot figure it out.

text files and xls files I have been able to access using SDSA,

Currently, my biggest frustration is that I loaded with SDSA  several  MP3 which still will play with the iXpand connected to the PC.

However, when I connect the iXpand to the iPhone,  I can see the files, but if I try to open(play) them, it states “File Locked” and that is as far as it goes.    I have found nothing regarding this in the documentation. Other type files, txt and xls, open OK.

Any tips would be most welcome.

To expand on my prior message:

I have two  applications I can run from the PC with iXpand connected to USB:  SDSA  and Encryptstick.

Each one has created  a “vault” on my iXpand.  However, these are separate vaults, called different names: EncryptsStick Vault and SandiskSecureAccess Vault.  Each app can put files in its own vault, not in the other App’s vault.

I have only one  App I can run from the iPhone:   iXpand sync.  It almost always sees the SDSA vault but not the Encryptstick vault;  sometimes, however it does the opposite.  I have not yet determined when …

Any help,much appreciated.

Further Update on my Prior message:

As far as playing MP3 files,  if they are placed in the MUSIC  directory or any of its subdirectories, MP3 files play fine and can be opened with any of my favorite  player apps on the iPhone;  problem resolved.

As far as  Encryptstick PC application, I cannot tell how to consistently  open files created by this app on the iXpand flash drive. Most of the time the iPhone’s Sandisk iXpand Sync application  cannot see the files or subdirectories.

So, perhaps the files are much better encrypted and invisible to any potential  intruders or thieves, but also invisible to the owner of the files?   Just joking. There must be a way. 

Welcome suggestions.