Is it possible to remove the empty file names under the voice/recording

After I delete a song file, it seems that the content is deleted but the file name is still there.

When I select “Listen to a recording”, it has to scroll through the empty files.

Is there anyway to delete these “ghost”  file names? I’m getting quite a few of them.

I tired factory reset but that affect it.

 thx, bob

oops, 2nd post because I forgot to check the “email me when someone replies”

Could it be that the player’s database is not reflecting the changes and needs to be recompiled? If you have a microSD card in the expansion slot, could you, with the player off, remove the card and then re-insert it, and then turn the player on again? This should force the player to recompile its database, and perhaps that may fix things.

thx for the reply, but no, there is no micro disk installed in my unit. So I guess having these ghost file names

is not normal ?

I don’t believe so.  Have you tried manually reinstalling the latest firmware, in case the code became corrupt?  (See the firmware upgrade sticky thread at the top of the forum.)  Even if you don’t currently have a microSD card in the player, if you have one handy, putting it in (and then taking it out, optionally) may do the trick to update the database.  

You mentioned “Recordings”. How did you delete these, by using the Delete option on the player, or by connecting to your computer and deleting them through Windows Explorer? I could be wrong, but I believe you have to delete these via the computer or the file names will stay on the player. Also, you may have to connect in MTP mode to remove all traces.

HI, I dont have a microSD so have to pass on that suggestion, but there was never one installed so not sure if that would appy anyway.  I did a firmware update using the installer (realized you said manually install too late), but I now have V01.02.09A.  It didn’t help, it still scrolls through 56 file names before hitting one of the 3 that have actual voice recordings. (at the top of the display it says 59/59 in yellow print).

Its starting to look like I’m stuck with the empty file names and it’s not that big of a deal, just a few extra seconds to

get to listen to a recording. 

I love this litte unit. The more I click around the more I’m learning all the t hings it can do.

thx again

bob

to Tapeworm,

I believe I deleted recordings both ways, manually from the device and in the voice folder on the computer, but

I’m fairly certain that I deleted most from the computer.  Not sure of the usb setting as I just am learning about the

MSC and MTP options.  Formatted it so I experiment with settings as I start recording and deleting.

thx

I have a Mac only, no Windows PC. I have many ghost files that I can’t delete at all. They don’t show up on the Mac anywhere, even when invisible files are shown. I can’t delete them at all, when I press “delete” nothing happens, they just stay there. The only way I’ve found is to reformat the enitre unit. I’m sick of reformatting. This is a big issue for me, requires another firmware update I think.

Have you looked into the freeware Hidden Cleaner for this?  It deals with Mac ghost files when transferring files from a Mac–it could be of use here, perhaps, as well.

I tried Hidden Cleaner and it didn’t seem to do anything except eject the Sansa device?

It’s possible it’s not compatible with Lion 10.7.5 or Mt.Lion 10.8.3? It was developed for Snow Leopard 10.6.3 and likely is a 32-bit only app. I did a “Get Info” on Hidden Cleaner and checked the “Open in 32-bit mode” box, but again, it didn’t seem to do anything except eject the Sansa.

Clearly there needs to be a firmware update because both my Sansa Clips are loaded with old ghost file names that can’t be deleted from with the Sansa software or from the Mac.