ID3 v2.4

I just bought myself the 8GB Sansa Clip today after reading some really positive reviews, and so far I love it. Sound quality is perfect and its great being able to use it on Linux (I had an iPod Touch 8GB previously). The only gripe I have with it so far is the lack of support for ID3 v2.4. If you’ve put music on your player that’s seemingly properly tagged yet still shows up on the Sansa as ‘Unknown’ then you’ve run into this problem too. It’s making it FAR more of a pain to get my music on there than it should be! I’ve searched the forums and I know people have said “It’s in the works”, but is it coming soon or is there ANY more information on the progress of this update available?

In the meantime, for anyone using Linux I’ve found a great command line utility to make converting the tags for use on the Sansa Clip a breeze; it’s called eyeD3. Install it, then do something like as follows to get your files up to scratch for the Clip…

First, to check what version of id3 tag is being used you can run a command like this:

eyeD3 -v Track\_01.mp3

 The “-v” option is basically asking for verbose information about the tag in the file, you’ll get a bit of info thrown at you and you should be able to see something like “ID3 v2.4” in there somewhere.

Then to convert and clean up the tags to make absolutely sure they’ll work I use this command (in the directory of the music files):

eyeD3 --to-v2.3 --set-encoding=latin1 --force-update \*.mp3

 What ths does is fairly straightforward, it’s telling the program to convert the v2.4 tags to v2.3, to change the encoding to a v2.3 supported one (my v2.4 tags use UTF-8 which v2.3 apparently doesn’t support) and also to force the tags to update, as eyeD3 will usually only update a tag field that’s been edited (e.g. if you changed the album or artist name etc) which we don’t need to do. Oh and the *.mp3 bit means apply this to EVERY file in the directory ending in .mp3 (that’s a handy trick for any command line user to know!).

Hopefully this is helpful to anyone who’s running into this problem, although I can’t stress how much more helpful a firmware update to negate the need for this extra work would be Sandisk! :wink:

Message Edited by garmur on 01-22-2009 11:43 PM

Yes Sansa,

Please update us on the status of the next update, please.

The ID3 tag problem is a bit of a sticky wicket.

Until then, I need a way to convert my tags on a Mac.

I have not had any luck finding a free software option for converting the tags on an Intel MacBook running OS 10.5

If anyone knows of one, please post a link here.

Love my clip,

recommend it to my friends, in part, because of the firmware updates.

Keep the firmware updates coming :smiley:

Happy Trails

for windows users, it’s very easy. just use mp3tag. maybe you can try and get it running under wine?

Message Edited by marc2003 on 01-23-2009 11:46 AM

marc2003, it works in wine 100%, thanks for the idea :smiley:

Still looking forward to not having to worry about this at all!

garmur, thanks for the info on eyeD3.  I’ll emerge it on to my gentoo box and try it out tonight.  This would only be an issue for some of my podcasts since my music is all in ogg vobis.  :slight_smile:

EasyTag is more or less equivelent to MP3Tag and runs on pretty much every OS known to man.  It the best GUI tagging tool for Linux.  It can easilly switch between tag formats and encodings.

Sansafix has indicated that 2.4 (and presumable better UTF) support will be coming in a future FW.

Skinjob, I had tried EasyTag before eyeD3, but It only writes ID3 v2.4 (the tooltip text on the ‘convert ID3v2 tags’ option in the preferences is out of date, it says it will use ID3 v2.3 but the checkbox for ‘write ID3v2 tag’ has been updated to say v2.4). And as far as I can see there’s no option to use v2.3 or to convert between the two?

puddlegum, glad you found it useful. Yeah most of my music is in ID3v2.3 anyway too, but anything I’ve edited in Banshee (or anything on linux, there must be a standard ID3 writing library in use that defaults to v2.4 now :P) uses v2.4.

@garmur wrote:

Skinjob, I had tried EasyTag before eyeD3, but It only writes ID3 v2.4 (the tooltip text on the ‘convert ID3v2 tags’ option in the preferences is out of date, it says it will use ID3 v2.3 but the checkbox for ‘write ID3v2 tag’ has been updated to say v2.4). And as far as I can see there’s no option to use v2.3 or to convert between the two?

Wow, are you sure?  If so, that must be a recent change.  I use Windows and recently changed computers so I don’t have all the requisite stuff installed to run EasyTag right now, but it definitely used to be able to do it.  I had pointed several other Linux users with tag problems to it and they all reported that using EasyTag to switch to ID3v2.3+ISO solved their problems.

garmur- I don’t know which version you’re using or how it’s compiled but it works for me with EasyTag 2.1.5.  This is what I see (abbreviated):

[X] Automatically convert old ID3v2 tag versions


[X] Write ID3v2 tag


Version: [ID3v2.3]

Charset:

    ( ) Unicode

    (*) Other [Western (ISO-8859-1)]

Hey everybody,

In iTunes you can convert Id3 tags.

Highlite the files you want to convert in iTunes, then right click, choose “convert ID3 tags” and choose what version you want converted to (2.3), hit enter.

It’s that simple.

iTunes 8, OS10.5

Happy trails…

having recently bought two sansa clips, i agree that lack of id3v2.4 tag support is one of the biggest issues.  

it’s been 9 years since v2.4 has been introduced - please, sandisk, implement support for it as a firmware update.

as an amarok user i have my tags quite well organised - and all of them v2.4. converting to 2.3 is not an option, as that would break most of non-ascii characters and editing them again would upgrade to 2.4 again (taglib behaviour). 

ps. could somebody over at sandisk stab the developer of this editor ? thanks. i wrote a post, battling with the friggin annoying issue that linebreaks upon pressing enter are seemingly randomly placed either one paragraph before or after where i actually want them. then my session expired while i wrote the post, so i copied post text, logged in again and wanted to report… only to discover that the first line only was copied. according to the message at the top (regarding the “keeping the language clean” bit), i won’t say what i think about the developer, but it’s nothing polite. thanks.

i just upgraded my v1 clip to latest firmware - .32 - and it seems that it actually reads v2.4 tags now. i haven’t tested to be completely sure yet - anybody else who can confirm that ? would be pretty awesome :slight_smile:

THIS is the information I was (desperatly) searching. Thousand thanks.

But is Clip8+ has the same firmware as Clip4+…

I will order one and telle you (but if it allows UTF[8] (not ASCII nor UTF[16]) it is v2.4 !!!

Now the question is does it uses other tage (vol nb and track nb, the moste critical ones on Clip+ , jacket graphic beeing not, for example :slight_smile:

Memory size does not matter. An 8GB Clip+ uses the same firmware as a 4GB Clip+.