ID3 tagging problems

Hi

I have my entire mp3 collection tagged with ID3 V1, and the fuze had problems with Genre and Album, so I asked in the forum and some people adviced me to moved all to V2. I did it and I got an improvement but the Genre problems persist. For example some songs appear with Rock, and others with Unknowork (yes  it puts the word Unkown and the last letters of the word that must be there, for example Heavy Metal and Unknowneavy Metal). I used Winamp to do this work (Real real hard work). The problems appears in a high percentage of the songs, it’s real frustrating.

What’s going on?

@dienapalm wrote:

Hi

 

I have my entire mp3 collection tagged with ID3 V1, and the fuze had problems with Genre and Album, so I asked in the forum and some people adviced me to moved all to V2. I did it and I got an improvement but the Genre problems persist. For example some songs appear with Rock, and others with Unknowork (yes  it puts the word Unkown and the last letters of the word that must be there, for example Heavy Metal and Unknowneavy Metal). I used Winamp to do this work (Real real hard work). The problems appears in a high percentage of the songs, it’s real frustrating.

 

What’s going on?

I also use WinAmp to do all my tagging (and to play my music on my computer) and I have experience the same problem numerous times (and it would mark artist name, album names and song titles).

I’m not sure why exactly it does this, some people around here will say that it’s because they weren’t tag in ID3v2 ISO format which causes problems with the Fuze.  Though WinAmp should be tagging the files correctly.  All I had to do to fix the problem was retag them (using Winamp) and it would then show up correclty on the Fuze (I’d just erase the field and rewrite the text).  Somehow that works.

So if you were to rewrite the information in the genre field it should work.  I realize you don’t want to have to do this one song at a time, so don’t.  Do you use the Media Library in WinAmp?  Add all your songs to the Media Library, and sort them by genre.  Now highlight all the songs of one genre (for example, let’s start with Heavy Metal).  Highlight all the songs that are of the Heavy Metal genre.  Right click and you should have the option to “Edit Files” (I think that’s what it’s called).  This will allow you to edit the tags of all the songs at once.  So change the Genre text and rewrite Heavy Metal.  Press enter and they will all be retagged that way.  Of course, don’t use this to edit song titles unless you want them all to say the same thing.

Do this for all the genres, reload the files on the Fuze and it should (hopefully) work.  You can also use a program like mp3tag to change the tags (make sure the program is set to edit the tags in ID3v2 ISO mode).   

@dienapalm wrote:

Hi

 

I have my entire mp3 collection tagged with ID3 V1, and the fuze had problems with Genre and Album, so I asked in the forum and some people adviced me to moved all to V2. I did it and I got an improvement but the Genre problems persist. For example some songs appear with Rock, and others with Unknowork (yes  it puts the word Unkown and the last letters of the word that must be there, for example Heavy Metal and Unknowneavy Metal). I used Winamp to do this work (Real real hard work). The problems appears in a high percentage of the songs, it’s real frustrating.

 

What’s going on?

Re-tag them with both v1 and preferrably v2.

I use and love Winamp, but I’m not so keen on it’s Gracenote database info or tagging abilities. When using it to rip CD’s, it comes up with some real off-the-wall Genre assignments, at least 50% need correcting because they simply are not right.

It also inserts garbage into the Comments field of the ID3 tag; anything from just the year of origin to a full-blown multi-paragraph review of the album! This can (and does) play havoc with playback on Sansas and must be eliminated.

So MP3Tag is needed to edit/correct this deficiency in Winamp. You should be able to correct your entire collection with very little time/effort by using MP3Tag.