I can't activate my ready Cache!!!!!!!!!!!!!! Frustrated

I’m getting really frustrated with Sandisk Tech Support!!!

My readycahe came without an activation key.  I called tech support and they gave me an activation key.  I put the activation key into the box and it says “invalid activation code, please try again”. I called tech support and they said they would escalate it to higher level.  5 DAYS LATER I get an email from tech support saying its a software problem.  I guess there is a problem with having to reactivate the software every time you boot the computer (which requires reentering the key).  I told them I wasn’t able to even initially activate the software.  He just kept refering to a software issue but said it was running.  

When I check the cache monitor it just shows a blue flat line at the bottom.  I’m positive its not caching anything.  I’m not even able to check the box “Enable Caching”


they just pushed a software update a day or so ago. go ahead and install and update the software. if your issue is tied to the GUI bug that they had you should be able to open task manager and look at the services tab. if expresscache is running the software is workign correctly. if not let sandisk support know and they should be able to take care of you. 

The new version of the software 1.01 did not fix my problem.  My problem is that I don’t have a valid activation key to even enable the caching.  Unless you have a valid activation key you CANNOT check the box “Enable Caching” in the software.  

that is part of the bug. the GUI shows not activated but it actually is and the service is running. like i said you can check the task manager services tab if the service is running and not stopped then it is working and it is a GUI issue. You can aslo check regisry editor in the following key to see if the serial is listed. if it is it is working. at any rate if you are having issues contact sandisk support and they will get it workign for you. 

HKEY local machine > Software > Diskkeepers > Expresscache > licence

This issue was solved by Level 3 tech support in two minutes.  Neither key that Level 1 tech support sent me was a valid key.  I thought my readycache was packaged without a key.  Level 3 tech support told me what document the key was hiding on. I was expecting the key to be sticker on the front of the instructions or easily visible like most other software products.  I put that key in and it worked.  Not sure why the two Keys that level 1 tech support generated did not work.  

Happy now!!!

I have a Lenovo T430s. I don’t know where the Activation Code is? It came with 16GB SanDisk. Thank you

If you did not buy the retail version of Readycache you will need to contact the host manufacturer for activation in this case would be Lenovo.