How to downgrade my Fuze+ 's firmware from version 2.38.06 to 2.37.01?

I have update my Fuze+ firmware version to 02.38.06. But I can’t get Rockbox run correctly. So how can I roll back my firmware version? I had copy firmware 02.37.01 file to root directory of Fuze, but it doesn’t work.

Please help my.

First off, you know you can just download the 2.38.06 version again from this site, and not have to use the inferior 2.37.01 version, right? As long as you donload it from this site, and not the Rockbox site, it will not use any Rockbox technology.

Second off, when you plugged the Fuze+ to your computer, did the Sandisk firmware start, or did Rockbox? If the answer was Rockbox, then there’s basically your problem. Here’s the prodecure I recommend:

Step 1: turn you mp3 player OFF.

Step 2: while holding down the the Volume Down key, plug the device into your computer. Do NOT release the Volume Down button for at least 5-6 seconds.

Step 3: if you have not done so, copy the firmware to your Fuze+. Make sure you copy it onto the Internal Memory, and not onto your External Memory card (assuming you have one). If you’ve already copied your firmware, you’ll have to change something on the Internal Memory in order to make the thing realize that *something’s* changed (since the Sandisk firmware has no idea what Rockbox does). For example , your could create a new blank folder. Or, you could proceed to do Step 5. Just remember to follow step four afterwards.

Step 4: unplug and, again, hold the Volume Down key for at least 5-6 seconds. You should see a sign on the device that says “Updating Firmware”. Just wait for it to finish.

Step 5: this part is optional. Reconnect the device to your computer, and delete the “.Rockbox” folder, since you don’t need it anyway.

… And that should do it.

PS: I’m sorry if this procedure confuses you. I tried to make it as simple as I could.

to answer the question you asked.

i don’t think you can, not easily anyway…

if you use the 2.38.06 and then put an older version in

you will get a failed message and it will revert back to 2.38.06

there may be another way though ?

I’ve also not used rockbox before


Thanks for your reply. I have try to update firmware to version 2.37.001 before. The procedure is following:

copy to my Fuze+ internal memory home directory and then Fuze+ power on. I see the  “Updating Firmware” strings and it holds several seconds. Finally Fuze+ start up. Although the firmware version is still 2.28.06. Hence I believe that the Fuze+ can’t be downgrade with lower version firmware.

You could try renaming the earlier firmware file to 2.38.07, so the fuze thinks it’s a newer file than the current

newest version - 2.38.06. Personally, I wouldn’t risk it. 

@leejey wrote:

I have update my Fuze+ firmware version to 02.38.06. But I can’t get Rockbox run correctly. So how can I roll back my firmware version?

If I recall correctly, SanDisk made it so one cannot install this previous firmware version once the newer one has been installed. There were some serious bugs in that version that were fixed and the company doesn’t want people going back and having those problems.

renaming the file won’t help.

the version number is gonna be read internaly, inside the firmware file.

i havn’t tried that though so it may work but its so unlikey i don’t see the point.

in my last comment i mentioned Rockbox as a hint :wink:

That may be your best possibility

If rockbox has a restore original firmware feature

tha that might help for an older version ??

again i havn’t used Rockbox so i don’t know.

just trying to offer my 2 cents…

personaly i see no advantage to using older firmware versions

i have been upgrading my FW as they have been released

and never felt the desire to down grade… i only tried doing it once

for testing purposes (related to a clock time bug)

current version is probably best in my opinion


you said “I can’t get Rockbox run correctly.”

maybe focus on trying to get what you got to work rather than changing it ?