version downgrade

i have a sandisk sansa fuze v02.03.33 and want to downgrade to v02.02.26 or lower.

is this possible? and may i have a link.

and if not, why?

why would you want to downgrade?

if its the slotradio icon, you can get rid of that easy, just change regon to other rather then US or Euro and its gone.

if its for rockbox, theres no need, you can just do a manual install like i did with the latist firmware works fine :slight_smile:

For what it’s worth:

http://mp3support.sandisk.com/firmware/fuze/fuze02.02.26.zip

You can use that basic link and try substituting previous firmware versions as well. 

Some devices won’t downgrade (maybe because Sandisk or AMS changed something and it needs a newer firmware?), only way to know is to try it and see if it takes the older firmware file.

CAMster1113 wrote:

i have a sandisk sansa fuze v02.03.33 and want to downgrade to v02.02.26 or lower.

 

is this possible? and may i have a link.

 

and if not, why?

Here’s the official 02.02.26 Firmware Update post:

http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&message.id=23276&query.id=69476#M23276

tanks guys big help.

and yes it is for the rock box.

i tried to put it on with my current firmware and it says refreshing media and not updating firmware.

and so i naturally assumed it would work with an erlier firmware and that not much can change from

the previous version so i thought to give it a try. ill post when i change the firmware and install.

what was your firmware version and how did you do the manual install AzureSky

Message Edited by CAMster1113 on 06-18-2010 09:38 AM

Manual install: Download the firmware, unzip it, send the .bin file (my version 1 is fuzea.bin) to the root directory (the drive letter) of the Fuze internal memory.

as said above, you just download the files and drop them on they player.

if you want to rockbox thats easy, just follow the guide on their site

http://www.rockbox.org/wiki/SansaAMS

i used latist firmware and manual install, was very easy, you may be able to do this with the SVN version of rockbox tool
http://forums.rockbox.org/index.php?topic=23544.0

the current latist firmware works fine :slight_smile:

ive been trying to do the same and it hasnt been working the player just refreshes media and doesnt want to upgrade. somebody please help…

and im on 2.03.33A

Refresh Database usually means you have bad tags or corrupt files. 

With the unit OFF slide the power switch into HOLD position so orange shows. Connect the USB cord to your computer. Press  and hold down the << button. Plug the USB cord into the Fuze.

This should force a connection in MSC mode. Look for the Fuze in Windows Explorer (Computer or My Computer). 

Right-click on the drive. Go to Properties/Tools (tab)/Error-checking and run it. That will check for corrupt files.  If it finds something, have it fix the problem. Don’t “save bad chains.” 

If Error-Checking doesn’t find anything, then see if you can see your music in MSC mode and take out the last few albums you added.  One may have a bad tag. 

And if that doesn’t work, you may have to Format the unit to wipe all the music off and start again, by connecting (as above) in MSC mode, right-click, Format. Again, that will erase all the music on the unit. 

thanks but i really would like to know how to downgrade. im trying to get rockbox to work in the long run. i tried manual install and that didnt work so i tried running the automatic install from Rockbox Utility as a sansa fuze v1 and it said i needed firmware 2.03.31 or lower so i was wondering if u can downgrade?

@enpugin wrote:
thanks but i really would like to know how to downgrade. im trying to get rockbox to work in the long run. i tried manual install and that didnt work so i tried running the automatic install from Rockbox Utility as a sansa fuze v1 and it said i needed firmware 2.03.31 or lower so i was wondering if u can downgrade?

Read more carefully.  It doesn’t say you need to downgrade, it says you need to find a firmware file for an older version (you don’t actually have to put it on your player, that’ll happen when you install rockbox).

But really you should just grab an updated copy of mkamsboot or an SVN build of rbutil, they’ll flash any version of the OF.  

enpugin, you want to do the same thing as i have and downgrade your firmware if it is updated. my sansa gave me the same problem and when i downgraded to version02.02 it worked. so follow the directions on the first page of this link and you should be fine. get the lower version driver. copy paste it in to ur sansa and then safe eject and it will update. then follow the directions to install rockbox on ur sandisk player.

Message Edited by CAMster1113 on 06-21-2010 09:16 AM

i tried to downgrade to 02.02.26 and that didnt do anything so i tried and succesfully downgraded to 02.03.31. from there i followed the steps for the manual install of rockbox, from rockbox.org (i used the mkamboot in a command prompt etc) with a 02.03.33 bin file and then put it on my fuze as fuzpa.bin (which the OF was) along with the .rockbox folder (even though that shouldn’t have affected anything) and still nothing. could you please try and give me some more help

sounds like you probably have the newer fuze revision that sansa is producing to block rockboxing, till the rockbox team get one of those units to mess with i doubt we will see them being rockboxed.

awesome sauce :frowning: thanks anyways

AzureSky wrote:
sounds like you probably have the newer fuze revision that sansa is producing to block rockboxing, till the rockbox team get one of those units to mess with i doubt we will see them being rockboxed.

They are not producing revisions to block rockboxing…that is a ridiculous notion. Where in the heck did you get that idea from?