Any trick to downgrade firmware / Rockbox?


I just purchased a Fuze V2 cause its rockbox capable.

Now my da… Fuze refuses to flash everything other but the 02.03.31 and 02.03.33 firmware.

I can switch between these firmwares with manual flashing, but I can’t downgrade nor use a RB-Bootloader-patched firmware.

In this cases he just doesnt start to flash after removing USB and the firmware file stays on the drive.

Its really depressing cause I only bought this thing for Rockbox.

Does anyone know a way around this? Maybe a possibility to downgrade to 02.02.28 or anything like that?

BR Robert

Message Edited by Rob2222 on 06-02-2010 07:25 AM

No idea from anybody?

ATM we have already 3 players with the model number:

BI 1004 CAHK-8GB

that dont accept custom (RB-bootloader-patched) or older firmwares than 02.03.31. :frowning:


BI  1004 CAAK-8GB

and older models (10 = year, 04 = month)

still accepts all firmware.

A pity, sandisk…

Rockbox is such a good firmware and you still get the whole money for the units …

BR Robert

Message Edited by Rob2222 on 06-02-2010 07:30 AM

I recently got a v2 Fuze too. In order to patch the OF (v2.03.33) with the Rockbox bootloader, I had to compile mkamsboot from svn and use that (instead of the pre-compiled version available for download). After that, everything worked as expected.

EDIT: The model number of my Fuze is BH1004CABK-4GB. Also, I couldn’t tell from your posts whether you’ve already tried a Rockbox-bootloader-patched 02.03.31/33 OF and it didn’t work; if that’s so, you can obviously ignore what I wrote, and I have no further advice. :frowning:

Message Edited by Fuzilli on 06-02-2010 03:46 PM

Thank you for your answer but unfortunately I have the right version and the right patched file, corresponds with MD5 sums of files that working at other people with other FuzeV2s.

The BI 1004 CAHK just dont start to flash firmwares other than .31 and .33 original.

We have already 3 people with the same model number and exactly the same problem.

BR Robert