How do I fast-forward 8 hours of an audio book?

I downloaded a 15+ hour audio book from our library system and want to begin near the middle as I listened to the first 8 or so hours on a previous download, which expired after the “borrowing” time was up. The book appears to be in one big file; that is, clicking the forward button doesn’t advance anything.

Fast Forward isn’t very fast; I’d rather press Play at bedtime and check it in the morning. But I’m sure you have a better solution.  :-)  Thanks!


my M200 resumes when I turn it off while its playing.  You can try that, so you are always at the same spot you stopped at.

I’ve run into a similar problem.  The battery died in the unit while well into a net library audio book.  The unit reset and I’ll have to hold the fast forward button down for quite some time to make it 6 hours into the 10 hour book.  Not very reasonable.  I wonder if Sansa could resolve that in a firmware patch?  I had a zen nano plus that had a graduated fast forward… the longer you held it down the faster it went.

This seems to be the one great weakness in these players.  I bought mine primarliy for listening to audio books while commuting, and it’s true that it always starts up where I left off, but if I connect to a USB port or do anything other than continuing to play the book, it will lose my place.  The fast-forward speed seems to be about 10x, so to forward 8 hours, you would need to hold the button down for 48 minutes.  Yikes.  Also, if you need to go six hours into a 10-hour book, you can always hold down the reverse button and back in from the end. (This will work if you have only one file on the player.  If you have more than one file, skip to the one that follows the one you want to listen to and then hold down the reverse button.)

An interesting observation:  I use my player to listen to books checked out from my library (wma format), and also books purchased from (aa format).  The player treats these two types of files completely differently.  The Audible books are not visible from the main menu.  In order to get to them, I have to press the menu button, select “Play Music”, and scroll down to “Spoken Word.”  Then I can select Audible files.  Some other differences:  The player ALWAYS remembers where I left off in an Audible file (even if I change batteries, or connect to a computer, or whatever).  Also, There is no sound when you are holding down the forward or reverse buttons.  It’s like the player realizes that the Audible file are (possibly long) books, so it’s more careful, but it thinks a wma file is just a song, so why worry?

It would be nice if there were a way for the player to recognize that a particular wma file is actually a book, and to treat it accordingly (ie, don’t lose my place under any circumstances).  This would not fix the slow-fast-forward problem, but it would be an improvement.

Thanks for the input! I ended up letting it play overnight. Other than using up eight hours of battery, it worked out well. The battery gave up before morning, but when I replaced it and turned the unit back on I found it was just about at the right place in the book. I’ll be sure to listen to the rest of it before it extinguishes.


Hey Spock

Audible is designed to incorporate true “bookmarking”.  So you can do wahtever you want to the player while its playing the book, and it will always remember the location.  The M200s do not have a true “bookmarking” feature.

Luckily, I dont listen to audiobooks, so I dont have that problem.  I do listen to Talk Radio that I download, but those are broken into 1 hr clips, so its much easier to deal with.

this is my first post in this forum, and I was coming in hoping to find a solution to the FF issue on my e260 since I mostly listen to audiobooks with files that are several hours long. Are there no options for speeding up either the FF or the Scan Song features? My husband’s iPod speeds up the longer you hold the button down. The Rhapsody software lets me drag and drop to wherever I want in the “song,” so I listen from my computer while working at it rather than using the player. The FF and Scan w/  wheel only go forward about 15 seconds at t time no matter how far I need to go!

AND to make it more annoying sometimes I guess I don’t hold it down hard enough (I mean, finger cramps set in), so that after several minutes on FF it’ll just skip to the next file! Then I have to start over!

Any chance we can get this feature in a firmware update? Or is there one that I’m missing? (I just updated firmware a few minutes ago.)


Message Edited by thepals on 08-20-2007 03:19 PM

Thepals, your question is in the wrong forum.

It was answered previously on E200 foram as… Fast foward through the song, then activate the hold switch.  now you can let go of the button and it will keep fast fowarding for you.  release hold when your done for it to stop.

Thanks for the tip on the lock switch.  This helps, but is a poor hack.  I’m hoping the Sansa will get a FF similar to the iPod: the longer you hold the button (OK, on my iPod it’s a control wheel), the faster it starts FF/FR.  Also, bookmarking for WMA would be appreciated.

I just got a M250 yesterday and loaded an audio book on it. It is a 150MByte WMA file. I cannot get the fast forward to stick, it keeps going back to the beginning. I found that if I keep holding the FF button, it progressively gets faster and faster. So I can get to 3 hours or so relatively fast. However, when I stop the FF, ie take my finger off the button, it always reverts to the beginning of the book and starts over. I tried the hold button during the FF and the time on the display stays where I want it, 3 hrs however the book is still being spoken back at the beginning. If I hit pause, the display reverts to 00 and everything starts over. HELP !!! 

Just upgraded the M250 firmware to V4.1.08 and the fast forward still does not work on my audio book. I can forward in the slow mode seconds at a time and that works. However, if I hold down the FF button, it gets faster and faster but when I release the button after being in this accelerated advance, the story does not advance to where the clock is pointing and if I hit pause and play, it goes back to 00. Any one have a fix for this or should I return the unit to Circuit City for a refund and find another type of player ?

That’s what mine is doing. I got it today.

My experience is similar.  Right after getting M250 I upgraded to 4.1.08 firmware.  It appears to have the progressive fastforward feature - but it doesn’t work correctly.  Specifically, if I’m listening to a 1hr WMA file from an audio book and I want to FF to 30mins I press and hold FF.  It starts slow but progressively gets faster (good thing) but if I go beyond 15 or rarely 20 mins in - it auto skips to the end and starts the next chapter!  If I go to 15mins only I can sometimes go in 1 or 2 min chunks (though much slower)  Also, I’m not having any luck with the auto resume where I left off.  I’m hitting pause then powering off.   About 50% of the time, when I power on the WMA starts at the beginning though the progress indicator stays where I left off and no longer updates as the track plays???  Any thoughts on this would be greatly appreciated!

I fixed my problem. I returned the Sansa M250 to Circuit City and got a Creative Zen V (Plus). This one works great and has bookmarking feature also. My book that I am listening to is 12 hours long and the Zen will progressively fast forward, remember where it was when paused or powered off. Forget the Sansa products.

I’m afraid returning it is the only fix there is. I followed through with their support and finally they said that the Sansa did not support books that were longer than 10 minutes except from Audible and that it didn’t hold the place either.

They followed it up with “Have a wonderful day!” which is pretty ironic now that I’ve flushed $40 down the drain. I can’t return it. I bought it through Amazon and technically it isn’t broken. Guess the Goodwill will get it.

Boo Sansa!

Thanks your post is very helpful.

It is nice to know that others had the same problem and that it is not me but the machine that is stupid