Help? Sansa Clip+ Unusable!

Okay, I’ve had no real problems with my two-week-old Sansa Clip+ until just today.

When I plugged it in, it was as if my computer had a hard time reading it, and it’s only gotten worse. The clip, in MSC mode, takes up to 10 minutes to finally show up in My Computer(I’m on Windows 7) and even when it does, every time I try to open it or even so much as right-click on it, nothing shows up and Windows Explorer will even crash at times.

When I plug the device in, it reads “Reading” and then alternates rapidly between that and “Connected”. “Reading”, then “Connected”, then “Reading”, then “Connected”, etc.

When I plug it out, it reads “FAT is corrupted” and tells me to plug it into my PC and do something(that “something” is cut off by the lack of space for the text on the Sansa Clip+'s screen). I have no idea what’s going on or what to do to get it working like normal again. I’ve restarted my PC multiple times, I’ve formatted my Sansa Clip+ and I have the latest firmware(and even if I wanted to manually update it, I don’t have access to the clip’s root folder to do so)

I’m using a brand-new USB cord, I’ve tried this on several computers and it had the same outcome, and all of my USB ports are working perfectly with my other devices. Every time I try the Sansa on, it gives me the “FAT is corrupted” error and shuts back down.

Why is this happening to me? Is my clip busto?

Trying it again, when I plug the Clip+ in, it only says “Connected” and nothing else. I can find it as a USB drive in My Computer but it still won’t let me access it. Windows also opens a window saying “H:/ must be formatted before it can be used. Format now?” and prompts me to format it, and when I hit Ok, it never formats the disk.

Going into Device Manager and checking the Clip’s properties shows “The device cannot start(Code 10)”

Running a chkdsk on the sansa in the Command Prompt just makes it read “The type of file system is RAW.  Chkdsk is not available for RAW drives”

I think it may have had something to do with Windows Update? The problems started as soon as I updated…and I don’t know to fix them now.

Please help. I think my Sansa Clip+ is seriously screwed up.

Time to telephone SanDisk Customer Service for support?

No need, I found the solution after doing a bit of research!(Funny how this is the second time I’ve asked for help on the forum and both times I managed to solve it all on my own :P)

The problem was that the hard drive was corrupted and unreadable, presumably because I ejected it the wrong way one too many times. Windows couldn’t do anything with it, so someone suggested that I run Ubuntu and try to format and repartition the Clip+ in that OS. Worked like a charm! Everything’s back to normal.

Thanks for the follow-up, with a difficult situation. And good for you!