Help! cannot delete Sansa clip + 2 content

I love my clip + 2 and I’m stuck - When I turn it on or connect it to PC it says - "device full, clear

90 MB." and shuts off. “Full” I guess it meams including the micro card I addedOnce I connected it to WMP and tried to follow the steps it became a vicious cycle, it would not let me do amything “because it was full.”  While I was doing that–it shows"no files" on the Sansa sync–I discovered a bunch of WMP files I hadn’t meant to sync at all (I think that feature must have been turned on permanently) that explains while the device if full.  So I deleted those files from the WMP library, but of course it does me no good since they’re probably still on the device.  I read some of the solutions about changing the USB function to "something or other" but it’s way above my head.  I don’t have a micro-card drive on my PC–but once again it may make no difference if the internal memory is full.   Help! I need some help! not just anybody" as the song says—actually yes ANYBODY.  I hate to have to delete all my files because along the way some of the music did go into the twilight zone on my PC and I had hoped ti sync files back to it from my device.  Thank you

The “Not Enough Space For MusicDB” message doesn’t necessarily mean the device is full. It more commonly means you have one or more corrupted files on the player.

See this SanDisk Knowledgebase article on the subject.

Thanks for your imput… tapeworm , much appreciated.  I knew it probably was full because of the

 types of files I saw were added without my knowing it—got to make sure my Sansa Clip +2 is

 not connected to my PC when I transfer other types of audio files.  In fact, none of that systematic

sync, it’s best.  Didn’t know it was on.  Next I pressed the top switch together with the middle one,

while I was connecting–per an older message.  I was finally able to delete, unfortunately as

indiscreminately as the little troll had copied my files.  Next the “fun” part, resending files

to the Clip.  That’s when I discovered that having transferred my music library to one of

my USBs–ye ole computer is on its last “gigs”–just didn’t work.  So I copied back my

albums back to my music and now it’s synchronizing again…Last step, deleting little by

little what I don’t want…But I got to hear some stuff I didn’t remember and I learned in

the process.  So this isn’t exactly tech-talk, but it micht help someone else.   Time to

eat today (lunch. or is it breakfast?) Time flies when one is driven and clueless.

 

inadvertinently downloaded entire music library onto sansa clip.  will not let me delete.  what do I do now?

@jeannegish wrote:

inadvertinently downloaded entire music library onto sansa clip.  will not let me delete.  what do I do now?

There’s a Format function in Settings > System Settings if you can get to it. That will erase everything (except firmware & operating files) in one fell swoop.

can anyone help I have a sansa clip 4  and when I try to put on music i can only get 6 tracks to load then it says full I have tried to delete all previous files and done a factory reset but it still will not let me load anymore.it does say it lso is saying i need to free up 90mb

 I am new to this so idiot proof instructions please

Is your player full of other content, so that there is no space left to add more music/files? To take care of that, you can connect your player to your computer, open up the Clip drive/folder/icon, and then navigate to where your files are and delete them; or more simply, you can re-format the player under its System settings option–but note that this will erase all your content on your player.