HELP !!!!!!!!!!!!!! Cannot copy music

I’ve got today Sansa express 1GB.
When I tried to drag and drop files to the My Computer\Sansa Express\Internal Memory\Music directory I have received an error message “The device has either stopped responding or has been disconnected”

however, the device is plugged ok  !!!   (I can do synch via media player).

What’s the problem?

OS: Win XP
Media Player ver 11

What does the express say on the front of it?  Hae you tried disconnecting it, and reconnecting it?

I have been trying to do the same thing… I can’t drag and drop files into it like a regular USB drive… I don’t like that you can’t seem to do that, not very easy.

However, what I was able to do was open windows media player and click on the sandisk express, then I opend a file with music I wanted to load and dragged it onto the sandisk express drag and drop area in the “sync” area…

That seemed to work and the files then show up on the player… Also you might have to “format” the player from the player its self to get the files to start working.

Hope this helps, and by the way, if anyone can figure out how to just drag and drop files into it like a USB drive - please let me know.

Thanks in advance.