GoList + Ratings

Hi all,

I have 2 questions, hope they are not repeated.

1 - I have a Sansa Clip Zip (8gb+8gb memory card) - my player always forgets the ratings I give the songs, this occurs every time i switch it off. Anyway to make it remember?

2 - GoList - Have read the forum saying i can only add a limited number of tracks you can have on it. However if I create another playlist, it doesn’t come up in the where  - whilst listening to a track I decide i want it on a playlist. - just like the add to GoList option. Is this possible or another way around it?

Thanks in advance.

Firmware 1.1.20p

There is only 1 GoList. You can manually add other playlists, but the GoList is the only one you can add any tracks to ‘on the fly’ (or on the player). To add a track to another playlist, you would have to edit the playlist on your computer, delete the one on the player, then transfer the newly-eidted one back to the player again.

See what Rockbox offers. Download the manual and have fun. Some people swear by it, others are happy with the OF. I could see a use if perhaps you recorded a bunch of music from the radio. Not sure if Rockbox would do all you want but should offer more options than the original firmware.

For some reason it keeps crashing on my system.

 Tried on both windows xp and 7.

The reason im using the GoList is because the rating system failed on me, and now the GoList (capacity wise). Can anyone think of an alternative?

Are you rating the tracks using the player itself? At least on mine, ratings information is saved; I haven’t had any ones drop.

Using the navigation tree on the Zip, I like to select “highest rated” to build a quick queue of my favorites. Additionally, the ratings transfer over using Windows Media Player (this requires MTP mode though).

Try setting the rating of a sample track, then later navigate back t that track. Is the rating saved?

Bob  :stuck_out_tongue:

I am using the player itself to rate my songs. I did at first use the highest rated songs to build a list but as it kept forgetting i stopped doing so and moved on to GoList but didn’t know there was a limted to the playlist.

I dont have the songs on the computer just on my sansa.

If I had them on my computer, what takes priorty? sansa or pc? And would they transfer both ways (rating wise)?

I’ve just noticed that when I add new tracks to the sansa, after it refreshes my ratings are gone. I need a solution, it i so annoying.

nope it did not save

Sorry about the delay in reaching you. I’ve been spread really thin between projects.

At the very least, song ratings programmed from the user interface on the player should be retained. Strange things are possible with synchronizing with the computer, but that side of the equation has a different set of issues.

Just to play devil’s advocate, I tried tinkering with song ratings using the Clip Zip. Like you, I have found song ratings to be useful. On this player, I have a microSD card mounted, so I can test both memory areas for proper function. Success. Song ratings are retained and changes are saved.

If your player is losing the ratings, following a normal shutdown of the player, it’s possible you have a glitch in your firmware installation. 01.01.20 is installed on my device, so I am quite sure it can work. I tried plinking the ratings on some MP3 and AAC (M4A) tracks to be sure.

What you can do is reinstall version 01.01.20 manually on your device. The Sansa Updater only upgrades, but doesn’t have the capability to reload the same firmware over an existing one of the same build.

Here’s the link to firmware 01.01.20. Follow the directions following Manual Firmware Update. Be sure to unzip the bin file before transferring to the Clip Zip. It should say “firmware Upgrade In Progress” upon disconnect.

Let me know if song ratings work after reinstalling the firmware.

Bob  :smileyvery-happy:

Hi Bob,

thanks for replying.

I’ve reinstalled the firmware as suggested. I’ve noticed that the exact time it happens.

The ratings do stay but are lost once it refreshes the media all ratings are lost.

(I am using MTP mode)

Im having the same problem… any solution yet?

Nothing yet, im still waiting