G-DRIVE 10 TB Enterprise not detected properly by Windows 11

Hello.

Recently I’ve bought this disk :

G-Technology G-DRIVE 10 TB Enterprise Classe 7200 RPM, 245 MB/s, con USB 3.0

it worked well with Windows 10 and even with 11, but since when I’ve re-installed Windows 11, it stopped to be recognized correctly. I mean, on the device manager I can see that it is working correctly and it is shown under the name "G-DRIVE USB SCSi Disk Device ; driver file version 10.0.22000.1 (WinBuild 160101.0800) " and it has been mapped as Local Disk (H:), but it says : “used space 0 bytes ; free space 0 bytes” ; I tried to attach it to a lot of different USB ports and USB controllers, but it didn’t work anymore. Usually for the USB disks I shouldn’t install a specific driver. And anyway, the company G-Technology hasn’t one. What should I do to fix it ? And yes, it works well under different OSes, like Linux and FreeBSD. The driver used is very old,it comes from 2006. but when I try to update it, it says that it is the most recent. No, I can’t re-format the disk. It’s full of data, I don’t know where to store 10 TB of data. Can u provide a most recent updated driver or a link where I can find it ?

This is the error that prevents the disk from being correctly used :

Device SWD\WPDBUSENUM{5494b1ad-a9ab-11ec-ade5-806e6f6e6963}#0000000001000000 requires further installation.

Driver Management has concluded the process to add Service WUDFWpdFs for Device Instance ID SWD\WPDBUSENUM{5494B1AD-A9AB-11EC-ADE5-806E6F6E6963}#0000000001000000 with the following status: 0.

I have no clue of what I need to do.

1 Like

Hi @WilliamsWoods
Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting: