Fuze won´t work (connect) in MTP-mode / winamp trouble

Edit: reinstalled winamp and tadaaa: mtp device recognized. BUT: as soon as winamp has loaded it, it crashes. Winamp simply closes, no error messages, nothing. PLEASE! Any program to manage the **bleep** playlists! (any prog that doesn´t simply crash) 

I tried connecting in MSC and that worked just fine, but almost all my stuff is saved under MTP-mode via mediaplayer (what is exactly what wont work) and I at least want to delete it. The player is revision 1, has firmware version V01.02.26E, and I am trying to use it under XPsp2. I tried several mediaplayers, same result: wont work. Is there a way to a least control and access the files saved under MTP-mode with ANY program? The last firmware rev. made it possible to use normal folders as you now so no need for the whole MTP-crap anyways. Ok, I could simply formt it and be done with it but then the Data i want to keep would also be gone. PLEASE tell me there´s a way to solve this without formatting the damned thing. Again: If I switch it to MTP and plug it in simply NOTHING happens. Winamp simply says: no portable device connected. 

Message Edited by Cornholio on 09-15-2009 07:25 AM

Message Edited by Cornholio on 09-15-2009 09:03 AM

You can still view the files you transferred using MTP in MSC by showing hidden files and folders. You can then format afterwards. I have read about others using Media Monkey to manage songs/playlist on their devices. Try doing a quick search for Media Monkey.

Edit: Nope, only WMP-11 runtime got the MTP protocol and that same piece of *** gets winamp to crash. I will try one other thing and then get the monkey-prog you named.  

yes well… I read the whole “winamp-crashes”-garbage is caused by WMP11 runtime. I therefore deinstalled said runtime and am back at the start. the whole MTP-device will not be recognized. It popped up just fine as long as the WMP11-crap was installed but then winamp wont work. The other way around inamp works just fine now but the player will not be recognized while running MTP-mode. I COULD delete the files manually after reinstallind the WMP-11-runtime but still - there was a time (if my memory doesn´t fail me) when both things actually worked, when the player was recognized and winamp worked just fine. The question is: is there a way to make the whole MTP-driver-whatnot work without the windows media runtime?I will try to install an older WMP runtime and post the results - perhaps the solution to the whole winamp+MTP-Problem is just a step away…

 


Message Edited by Cornholio on 09-15-2009 08:28 AM

FOUND A SOLUTION! WMP10 is the way. (or at least now it works) I installed WMP10, then went to hardware management where the fuze was shown with a yellow questionmark, rightclick, reinstall driver, search online, and go. It found something online, installed it and my winamp kept running. I can normally edit all the stuff. Seems like it´s only the WMP11 runtime that f**s around in the backround. here´s what you gotta do: ditch WMP11 and WMP11 runtime via software-management (if that crap defiles your harddrive), ditch the mtp drivers in hardware management, get and install WMP10, then go to hardware management and allow it to search online for drivers. Install said drivers, start winamp, and what you have is winamp with MTP support. ha, i´m proud of myself. 

Just thought I’d mention another possible solution… I had exactly the same problem.  I was reading through the forum and somebody noted that they too had the issue due to some PS3 USB drivers installed on their system.  Once they uninstalled those, it worked again in MTP mode.  The only thing I had installed recently was a Microsoft webcam (installed on all three of my PCs at once time).  On my laptop I had previously uninstalled the software through add/remove programs but that PC still had the problem.  So I then uninstalled my USB host controllers and then scanned for new hardware.  Windows re-installed and then my Fuze worked in MTP mode once again.

I have Media Player 11 and didn’t mess with it.

Anyway, I hope this helps somebody else with this issue.

Regards