Fuze freeze when tried to play song

 Hi, i bought Fuze 2 GB today. I charged it, manualy update firmware, put few songs on it and when i put play all songs it freeze. I formated it, try diffrent mp3 - all the same. Radio, menu all works, but when i tried to play only reset helps. What is wierd - Fuze shows duration of song as -0:00.

Can anybody help me with that? Or maybe only i can do is send it back to shop? :( 

Message Edited by Rook on 05-26-2009 06:56 AM

Are you sure the song is an mp3 and not m4a (from iTunes) or another format? The Fuze plays mp3, wma, ogg, flac and aa.

The problem could also be a bad ID3 tag. Look at the song in your computer with Properties/Summary/Advanced. Are there any unusual characters, not letters or numbers, in Artist, Title, etc?  Are there very long Comments or comments with imbedded images? 

The Fuze is not as flexible about ID3 tags as your computer is. Try making the tag simpler and see if the song plays. 

To fix a lot of tags at once, get mp3tag

 i tried only mp3 and flac. now i’m trying only one mp3 - i reedited tag in this mp3 (using autotag in winamp) and still tha same. two times it starts play - but not music - only some noise and distortions 

ok, i downgrade firmware  to 1.01.11 and now its working normal. why it wont work with newest firmware?  maybe any other version will work? whre can o find previous versions of firmware?

Message Edited by Rook on 05-26-2009 12:14 PM

i’m having a similar problem with my fuze 4gb revision 1 and updated to firmware v.01.02.26F but mine does not go to -0:00 it just stops playing and stops responding and screen freezes and i must turn it off

i formated the drive, and restored to factory defaults, and put a single untagged mp3 on it and it still hangs after a few seconds of playing (usually under 45 sec)

the player doesn’t seem to have this problem with ogg since it plays them flawlessly

this is a obviously a major bug and it needs to be fixed asap, since i would really hate to go back to the old firmware and lose replay gain…

Message Edited by BrD on 05-27-2009 01:09 AM

Odd, something similar happened wth me when my sis got me some songs that were encoded with some Lavf Program…

it played a sound then skipped to the next song without freezing. All I needed to do was convert it in iTunes and it played fine, but i had to fix the tags slightly…try converting it to Mp3 with iTunes or another program and see if that helps.