Fuze doesn't play songs with numbers in their titles/filenames in correct order

Hello there,

I bought my Fuze yesterday and so far I’m very satisfied with it. But I’ve come across a weird thing. My Fuze doesn’t seem to play MP3s which have numbers in their titles correctly. For example I have problems playing this file:

  1. Star 69.mp3  -  it’s from the Fatboy Slim ‘Halfway Between The Gutter And The Stars’.I tagged it with Mp3tag, filled in the Title, Track #, Artist and Album. But for some unknown reason when I turn on my player, go to Music -> Artists -> Fatboy Slim -> and select the album this particular song is always at the end of the playlist, even though it’s the 2nd track on the album and I have tagged it correctly with the track number. So I tried renaming it to 02. Star Sixty Nine.mp3 (thought it might help) and wow - it helped! Now it’s played properly as the 2nd track. So I tried something different - I added something like ‘123’ to the end of the other’s file name and bam - it ended up at the bottom of the playlist.

But it didn’t work with the second track that contains number in it’s title: 04 - 42.mp3 from the Coldplay’s latest albums. I have the same problem with this one - it always is placed at the end of the playlist - no matter what I do - I changed the title tag, filename, track # tag - it’s always played as the last one…

A little confused I tried changing my connection type from MSC to MTP. It worked like a charm. But I wonder why it doesn’t work when I transfer my files in MSC mode? I’m using Vista laptop and I simply drag-and-drop my folders onto the player, without WMP and things like that.



Ok guys, problem solved. I checked the settings of Mp3Tag and the tags weren’t in ISO-8859-1. Now it’s all fine.