froze and now it won't turn on

It froze while on the radio became unresponsive but now it won’t turn on. I’ve tried resetting it, connecting it to the pc (didn’t recognize it) tried connecting in MSC mode and it said i needed to format it before I can use it. tried formatting it but it just told me it couldn’t.

What, if anything, happens when you try to reset?  And are you holding the on switch down for a considerable time?  While the typical time to reset is 20 or 30 seconds, some people report as long as 60 seconds or more.

Nothing happens, the screen stays off and the computer still doesn’t recognize it. I’ve tried for about 2 minutes and still no change

Hold the Power Button over 20 Seconds. Leave the Power Button and press Again!.

This Reset the Player. The leave and Again is important.

Have the Player Akku Power?

Plug the Player 30 Minutes on the PC to load and repeat Reset Method.

Was able to go back to the store and replace it (I got their warrenty because i’ve gone through atleast 3 other clip+s which physically broke on me (I get them because they’re cheap)

Thank you!  I thought my clip zip was dead and did exactly as Koto said above and it came back to life.  It seems to have gotten messed up when I restarted my computer with it still plugged in…will try to remember to avoid doing this.

Yes, I had the same problem.  I did as described and it worked great.  

My Sansa Clip Zip does not want to turn on neither after I held the switch on button for more than a minute and after then I released it and pushed it again. 

It’s not recognized neither by my desktop nor my laptop. 

It worked fine for a year. 

Now nothing. 

I’ve tried everything what is suggested on

I also held the ‘center’ button for more than 20 seconds while (and after) I connected it to a computer. It did not help. 

I would appreciate any suggestion in this subject. 

Thank you.

This may be too obvious, but since you didn’t say, I gotta ask . . . did you try charging it? Sometimes leaving it on a charger for even a day or 2 will bring it back to life. Worth a try anyway.

My unit refuses to turn on except for when being charged. I’ve tried the reset trick, nothing - and I’ve held it down for 20 seconds, 60 seconds and even 120 seconds. All I got was a cramp in my finger. The thing is barely used, maybe four times a year for the past 2 1/2 years. It is fully charged, I tried that for a full 24 hours today. Thanks for any help that anybody may provide. It’s a Sansa Clip ZIP model SDMX22

@clore wrote:

My unit refuses to turn on except for when being charged.


Sounds like a lead wire from the battery has become broken or disconnected.