Folders appear empty when they aren't

I am a new user and though competent wouldn’t consider myself particularly savvy.

I only want the P3 player to listen to music or audiobooks while working so once charged I loaded it up with some books.  I just used drag and drop (coincidentally it would only allow me to put them in the Music folder).

Everything worked fine, it charged, I listened etc.  Until I came to change the books for some new ones.  I connected to the computer (Win 7) in Explorer the player turned up with the preset folders but I was told there were no Folders in the Music Folder.  I checked on the player and they are definitely there.  I tried loading a new file on anyway.  I was told there was not enough room.

I checked how much of the player was used - nearly all of it - yet checking each folder individually this didn’t add up!

So I cannot see any of my files, I cannot delete any and cannot put new ones on.  I tried on 4 different computers.

I tried to sync with Media player thinking it would wipe out what was on there.  No go - it just tells me there is not enough room.

Am I missing something obvious?

It could be a USB connection issue.  Basically put, your computer only sees the files put onto the player using the USB mode (MSC or MTP) that the player then is connected to the computer under.  And so if files were transferred under MSC mode but you’re now connected under MTP mode, the computer won’t see the files.  Complicating matters, the player’s “Auto” USB setting will try to connect under MTP mode but then default down to MSC mode, if needed.

Best practice:  set the player to 1 USB mode, MSC or MTP (MSC can be most trouble-free, but MTP mode is needed for protected files).  And also, clean up your player’s files first–easiest just to re-format the player under its Settings and then transfer the files you want back to the player (if the only copies of your files are on the player, transfer them to your computer first, switching the player’s USB mode if need be).

Ok maybe when I said I was a competent computer user I was kidding myself.  I am really sorry if I am being a time suck and all round needy but I have tried to find out more about what you are saying and can’t seem to pinpoint exactly what I need.

I understand what you are saying and it makes sense to me I am just not clear on how to implement it.

Firstly nothing on the player is not replaceable so I need to start by formatting the device?  Do you just mean wipe the whole device by reformatting from its menu on Windows Explorer?  Or is there another way to do it?

Secondly how do I switch the USB mode?  Is this something I dio on the device or the computer?

Again I’m really sorry if I am being stupid.

The infamous Auto Defect strikes again!

@maylin wrote:

 

I understand what you are saying and it makes sense to me I am just not clear on how to implement it.

 

Settings > System Settings > USB mode (on the player)

@maylin wrote:

 

Again I’m really sorry if I am being stupid.

 

Not at all . . . just unfamilar with how these things work. It’s one of the reasons the forum is here! :smiley:

Easiest way to erase the content on your player:

Under the player’s Settings - System Settings menu, there is a Format (or Reformat) option.  Select it and the content you added to your player will be erased (this will not erase the player’s system files).  

The USB Setting option also can be found there, to set to MSC or MTP (avoid Auto!).  

Thank you both.  It is not only sorted now I also have a much clearer understanding of wwhat is going on.

Excellent service and a very satisfied user :slight_smile:

:laughing:

I think that the MSC/MTP USB mode issue was the best lesson that I learned here, when i got my first Clip. An unknown issue for many of us, until you are faced with it–and then, so ever easy to handle. Enjoy the player! :slight_smile: