FM Radio Station Won't Change


Just got my Sansa Clip Zip. I wasn’t too concerned about the MP3, but really wanted it to have a radio when I work out. I’m having trouble with the radio. Here’s what I do and what happens…

I tend to change the station often by hitting the center button. Normally it changes the station to the next preset. Often it doesn’t change station but rather stays on the same station. The display says the station has changed, but it doesn’t. Sometimes the station goes silent and or it has extra static, but regardless, the station does not change. 

The device is not paused and pausing and unpausing doesn’t fix it. The device isn’t “locked” as the display shows the station changed, but the sound is of the original station or static or nothing. The only way I can get my radio to work is to power off and on again or format. Then device works for a while, but often goes back to this bad state if I change stations a bunch. 

Is there a fix or workaround. 

My device says I’m using Version: V01.01.21A, if that helps.


Try rolling back to firmware version 01.01.20 and see if that changes things.

Btw, you described your situation perfectly. If everyone gave as many exact details as you, it would sure save a lot of back & forth around here. :laughing:

Thanks. I’ll keep that option open for a bit. Sounds like a pain, but if that what it takes. 

Meanwhile, I’ll see if I can catch exactly what makes it happen. Sometimes it happens often, other times it happens once in a while. I’ll also look to see if there is a workaround (as in, don’t do it that way, or if there is a way to get it back working without a restart).

@bessermt wrote:

Thanks. I’ll keep that option open for a bit. _ Sounds like a pain _, but if that what it takes. 


Not at all. Takes all of about 5 minutes _ max _. Download the f/w .zip file, extract it and copy to the player. Unplug and restart when prompted.

Couldn’t be easier. :smiley:

You also could try reapplying the _ current _ firmware, in case this simply is an issue of a firmware glitch that developed over time.  The latest firmware is available in the firmware sticky thread at the top of this forum.

Again, it’s very easy to apply and just takes a matter of a few minutes.

Just poking my nose in again after using the radio for a while. 

Here’s what I see to reproduce the problem. Maybe someone could do the same and see if they have the same problem?

  1. Set up some radio presets. Not sure how many, but I have about 10.

  2. Turn the device off and back on.

  3. Use the presets to cycle though stations. 

  4. Find a station you like and listen long enough to for the display to black.

  5. Press the center button to turn the display on and immediately (it is important you do it immediately) start pressing again to cycle the stations.

  6. Continue cycling stations. This will work for a while. 

  7. After not too many station changes you will notice the station display is changing but the station you are listening to isn’t changing.

When it happens, there is a noticable delay in the station display changing. If that helps. 

So, then, perhaps don’t do step no. 5 . . . .

That just seems to make it happen quicker. It still happens with or without step 5.

I downgraded my OS and it still happens. I’m getting more familiar with how and when it happens. 

The quickest way I can make it happen is to go through some preset stations, listen to one station for a while (10 minutes), then press the middle button twice. Seems like without listening for a little while it is hard to make happen. Once I listen for a bit, then it happens quite easy.

I’m going to check back here in a week. If there are no other suggested solutions, I’ll contact SanDisk about a replacement/refund. I suspect a refund will be required since it seems like a software issue and a new device won’t fix the problem. 

It would be nice if someone would confirm this for me. I would like to know if it is just a defective unit I purchased. If not, I’ll assume they are all defective and go back to Amazon and give the device a poor review. 

@bessermt wrote:

I’m going to check back here in a week. If there are no other suggested solutions, I’ll contact SanDisk about a replacement/refund. I suspect a refund will be required since it seems like a software issue and a new device won’t fix the problem. 


SanDisk does not issue refunds; they only replace warrantied products. You would have to return it to your dealer (in this case, Amazon) for a refund. But even they have a time limit of when you can take advantage of this, so don’t wait too long.

I doubt that this is a software issue, as the earlier poster suspected–I don’t have this issue at all.

Sounds like a control issue with the onboard FM receiver chip. If reapplying the firmware doesn’t fix the issue, it’s likely a simple hardware issue. Troubles with the FM receiver are rare as hen’s teeth, rest assured.

If you just purchased the device via Amazon, their return process is great. With any retailer, within the first 30 days, returns to the seller are simplest. Beyond this, SanDisk has you covered. I’d exchange the little guy for a new device.

Reference the steps you have taken here, and they’ll fix you up.


Sounds like they will replace it with a working unit?

I would still like to have someone (ANYONE) confirm the problem. This would help me know if it is a software or hardware problem. 

I’ve been refining one what makes this happen with the least amount of work (although it is pretty obvious). Here’s what I have so far. 

  • Set your presets to stations to music stations with good reception and shows the currently playing song in the display.

  • Find a song you like and listen until the screen goes black screen saver.

  • Finish listening to the entire song.

  • Listen to the next song part way through.

  • Start switching stations with center button using your presets.

  • Keep switching stations until you notice the stations are no longer changing even though the display shows them changing. 

  • Often the station it is picking up has only static, sometimes it is an actual station. 

Please, can anyone reproduce this problem?


I’m wondering if there is any connection with the display showing the currently playing song and the station changing the song causing the problem. Seems like there’s a connection from my viewpoint, but I don’t know why that would matter to the device.

I updated the firmware once, reloading the current version. I’ve downgraded to V01.01.20A.

Decided to return and excange. Same problem still with new unit. Very frustrating. 

I’m in a location with poor reception on the radio, if that matters. Still same result. Change station with presets works fine. Listen to a song for a while then start changing stations. Do this enough and the display show the station changing, but the radio station isn’t actually changing. A reboot does fix it until the next time. I can normally get it to happen within 15 minutes of listening. 

Still looking for a solution. 

Still have problem with a replacement unit. I notice that when it happens you can’t press and hold the forward to the next radio station and have it look for the next station. It just steps one frequence step at a time until you release the forward button. 

It would be really nice if someone would reproduce this problem. I’m confident that it must be a software problem, otherwise why would a new unit still fail. 

It is easy to reproduce, but you need to spend 30 minutes to do this. 

Reset the device.

Set up some presets.

Listen to the radio.

When a song comes on you don’t like, skip to next preset until you find a song you like.

Listen for a while, then when a song comes on you don’t like, switch stations.

Do this for a while and you will notice the station won’t skip to the next preset. The display DOES change, but what you listen to isn’t changing. 

How do I fix this? ANYONE at Sansa listening?! I’m really frustrated with this. 

Anyone? Anyone? Why no reply?

@bessermt wrote:
Anyone? Anyone? Why no reply?

Probably because no one has an answer for you. Either they don’t have the problem, or or not motivated to try and reproduce it by constantly changing stations until it (may or may not) happens. Most people find the station they want to listen to and then leave it; they don’t cycle through all the stations repeatedly until it overloads and freezes up.

Seems like the issue doesn’t happen if listening while charging. Not sure if that helps.

This is easy to reproduce in less than 15 minutes. 

Listen to radio. Find a station you like. Listen for a few minutes. Start changing presets finding another station you want to listen to for a few minutes. While cycling looking for the station you will notice the station is no longer changing.