Flash Drive issue

I went to delete all the mp3’s from my music folder and replace them with different ones it looked as if all the files deleted but when I went to reload the folder I could only put about 1.5gigs of info on my 8gig drive. When I looked in the music folder it only had about 1/4 the mp3’s I had tried to copy over. I disconnected my Fuze from my PC, allowed it to refresh and then opened the folder on the Fuze screen and noticed that all the songs I had on previously were still there.  I reconnected the Fuze to my PC and opened the folder again but only saw the newer files I had just added. I deleted all of them from the folder to make sure it was empty and then I check the drive properties and it claims the drive has 4.9gigs of data on it. I checked every single folder and there’s nothing on the drive, at least when connected to my PC. When disconnected from my PC and I open my music folder on the Fuze screen there I can see and play all the music files I had originally tried deleting.

I though that updating the firmware might solve this issue but now I can’t get my PC to recognize the drive when it connects.

I’m not quite sure what you’re saying, here. Are you basically saying you tried to delete some MP3’s to make room for other songs? However, when you delete the songs, the space they occupied isn’t being freed?

Are you by any chance running a Macintosh computer? If so, you have to empty the recycle bin before you unplug the device. I would try checking the FAT32 partition using the “Disk Utility” application. See HERE for instructions (you will have to scroll down past the Windows Part). Of course, because this page if for some external drive, most of the cable-related stuff will probably make little sense. Just plug in the device like normal.

 If you’re running Windows, I have no idea what might be causing this. However, you can follow the instructions on the link above and see what happens.

As a last resort, you can try reformatting, although that will wipe  everything , so if there’s anything important, you should back it up, assuming you haven’t done so, already. It’s probably best to do this from the directly from the device, using the “format” option in the settings menu.

A quick note for the future: you don’t really need a PC to delete individual songs. You can delete them one-by-one directly from the device itself, although doing this for large amounts of files can be a pain.

Updating the firmware will reset the USB mode to the default, Auto Defect (which tries to connect in MTP Mode). This can sometimes be problematic in connecting to a computer. If you go into Settings > System Settings > USB Mode and switch it back to MSC mode your connection issue should be solved.

As far as files not deleting, formatting the player will erase all user-added content and free up all the memory if simply ‘deleting’ them does not work. You will find a Format option also in the Settings > System Settings menu.

@halonachos117 wrote:

Are you by any chance running a Macintosh computer? 

Upon first glance I thought of this too, but the OP clearly stated he was using a PC. :wink:

Ah, I see he did say specificaly “PC”. My bad.