Firmware Says I am Not Connected (I really am I swear!)

I just got my Sandisk this morning and I’ve wasted my entire day trying to get it started.   

I followed every procedure to the letter in setting it up.  When I installed my Firmware Updater and tried to run an update, it told me that no internet connection existed!  This is obviously false, as my post here testifies.  I called technical support, who tried to tell me it was my anti-virus (Norton) program that was preventing the connection.  Knowing this to be ridiculous, just to humor them, I even disabled my entire Norton System, dropped my firewall, lowered every security setting, did everything but strip to my boxers, and it still cannot connect.

Tech support was useless on this matter.  They acted like they had never heard of this problem before, and I am the only guy on this planet running Windows XP on an HP computer.  Their solution?    One tech tried to talk me into just being satisfied with the firmware version that came on it.  After I explained to him the many reasons that this would never happen, he suggested I go to someone else’s house and try it on their computer!!!  Yes, that’s right.  I was told to either “live with it” or hijack someone else’s computer every time I wanted to check for an upgrade.

I’ve tried running the program from the site, downloading it to my computer and running it as an .exe, and I’ve uninstalled and reinstalled it about a dozen times, and I fear I am wearing out my computer by re-booting it about 4 dozen times trying to get this cheap little piece of equipment to work.  I’ve explained my problem to so many techs, I’m afraid that if I explain this one more time, my brain will burst into flames and scorch my really nifty haircut.

I am on a cable connection, btw.   The only help I’ve received from Sansa is an email directing me to this forum.  Oh, they did tell me to “have a nice day.”

So… what should I do?  At this point, the only option I see is returning it for an iPod Nano.  Is there any way to “tell” the updater that I’m on cable broadband?

assuming you unintalled and re-installed it, it would be hard to tell you exactly what it is thats stoppping your connection. Worst case scenario, you can ask SanDIsk to email you the individual firmware files to load on your player. They send them as a .mi4 and a .fmt to drag and drop onto your player.

You wouldn’t have some kind of firewall or anti-virus in place, would you?  Or maybe some kind of odd proxy setup?  My money would be on some “security feature” blocking the updater’s access to the internet…

Try contacting SanDisk Tech Support and having them email you the firmware update files–you can then drag and drop them to your device.

what about if u used the cp as a limited user i erased the data and now i can’t set it to recovery mode


same thing on different computers?

I don’t have any security features that could be interfering with this (I’ve dropped my firewall, deleted my firewall, quit my Norton Anitvirus, and it still says it cannot connect. 

I do go through a proxy server, but that does not interfer with any of my other dozens of products, both hardware and software, accessing the internet for upgrades, etc.  This is the only product that has ever given me any problem.

If this cannot be resolved, I’ll have no choice but to return it for the Black iPod 8gig Nano and see if I have better luck with that (or if there tech support will help me work around the issue).  This is getting kinda ridiculous.

I’ve been thinking about this one for awhile…

I saw a post earlier, that SanDisk said they could email somebody a firmware update… i think.  Did they offer you that when you contacted them?

I was not offered that as an option when I called, but I just found the update in my email (it was filtered as spam, evidently) !!!

Thank you ALL very much!  This rocks.

By the way, it was sent from someone named Lance.  I don’t know if he is a tech on this board or not, but the fact that they read my comments here and, without even being asked, sent me the latest firmware updates, is an indication that I made the right choice by going and sticking with the Sandisk!  The email was a complete surprise and brightened my whole week.  The very fact that it was unsolicited and allowed me to avoid another call to tech support made every second of every minute spent getting to this point well-worth the effort.

Did I mention that I love this thing?  I consider it a life-changing event.  I don’t go anywhere without it.  I can’t imagine being in a waiting room or stuck in a car or room with a really boring person without my Sandisk.  How did I ever live so long (while avoiding murder charges) without it?  Now my life has a sound-track.   I am living in my own music video.  And I can listen to my downloaded radio shows any time I want!  No longer do I have to time my drives just so I can listen to Art Bell.  It is on whenever I want it to be, and commercial free!

There is no doubt in my mind that the Sandisk blows away anything else out there based upon features and abilities alone, and now their customer support has stepped-up and proven once again that we made the right choice in chosing the Sandisk over all that other stuff.  I feel like I’ve just opened a new toy all over again!

Lance, you ROCK! 

With customer service like this, I am going to buy more Sansa products including more of their MP3 players, no doubt. 

Message Edited by Sanitized on 08-09-2007 09:24 PM

I’m having the same problem with my Sansa e250.  The firmware updater pops up a dialog error window stating “There is no internet connection.  Fix the problem and try again.”  Anyhow, I wanted to know how I can get the " .mi4 and a .fmt" files so that I can update my firmware manually.  I’m not sure if I even need to, but considering I’ve spent well over two hours just trying to get updated to the .12 version so that the perpetual “Refresh Database” state would go away.  If anyone could tell me how I can get those files, I would really appreaciate it.


If you haven’t already done so, contact SanDisk Tech Support–i think they can get you those files.


just bought a Sansa Express and tried to use the updater. Same error message that internet connection is not available. But I have it.

One question since this “updater” method does not work very well in the world, why not just publish the update file directly as all other companies…?


GUYS HELP! i got scammed on my sansa… i saw this 7step to fix my sansa but i didnt know it was a scam! help me guys everytime i turn on m,y sansa all it says is failed to load main image please switch to recovery mode. guys pls help me ASAP!

just reload the firmware and the sansa.fmt, instructions should be in the FAQ’s

I have the same problem, when trying to check for updates I get the ‘no internet connection found’ message. Can anyone from Sandisk respond to this? I want to check to see if I have the latest firmware. I am having all sorts of problems with this and Napster to Go.


houghtby, what kind of OS do u have and do u go thru a proxy?

I also get the “There is no internet connection. Fix the problem and try again.” message. But when I click on the link in the Updater About window, Internet Explorer launches and the Sandisk home page appears.

I am using Windows XP SP2 with a phone line connection. Bill Gates knows I am connected why doesn’t your Firmware Updater?

Thankfully, the actual updates for the Sansa Clip are linked in that forum and the direct installation is simple and quick.

Sansa Support: Please add another user who has this problem!!  I have tried to install the Sansa Updater on two different systems - one running Vista Ultimate thru a proxy, one running XP Pro at home (no proxy AFAIK) - but no joy.  I am running the Windows firewall on both systems and see no evidence that it’s blocking the updater (it never asked me). Obviously you have a widespread problem here, please fix it!!!  This is really frustrating & I’m ready to return my unit (it’s a refurbished e250R I recently bought from

So … how can I get my update?

 - Bob

Update: Since posting I’ve found my way to the e200R-specific instructions, and verified that I already have the latest firmware. Nevertheless… Sansa Support, the updater is broken & makes for a very frustrating user experience.  Can you get this fixed pretty please??

Message Edited by BobTheNob on 12-17-2007 05:23 PM

Message Edited by BobTheNob on 12-17-2007 08:42 PM