[Firmware] Sansa Express 01.01.12 firmware released

I have a SanDisk Express 1G, I am running MS Windows XP professional on my work computer so need a driver that it can use on this computer. Where can I get it and what is the name of it?

I managed to update firmware to 1.01.15 with the Sansa Updater. First, I plugged the device as a MTP device. After the Sansa updater recognized my Sansa Express, before downloading the firmware file, I setted up driver as USB Mass Storage Device. After this, the update went well.

For people who doesn’t know how to switch between MTP and Mass Storage(in win XP at least, I don’t use vista):

Right click My Computer->Properties->Hardware tab->Device Manager

Down you will find MTP device

Right click on it - properties-update driver-install from a speciffic location(advanced) - don’t search -

Make sure that compatible is checked and then you will have a list to choose between MTP device andUSB Mass Storage Device.

I’m not sure why, but it didn’t work on any computer. On the work I didn’t manage to find Mass storage driver

Hope this will help.:manwink:

BTW, if you make the upgrade manually, choose american version, european does not have FM radio menu

got a serious problem.followed all update intructions but when it comes to pressing of the volume button nothing happens.well it did ask if i wanted to format,which i did.but the update process is stagnant,plus my player is blank and is only read as a usb disc.

plz help

Wich method have you tried? The sansa update application or the one with the .sys file? I recommend the software. It works for me.

I moved the file StMp3Rec.sys o "C:\windows\system32\drivers" then I connected the device holding the (-) button and the installation window appeared but it failed to install the device, it says something like (i’m translating from spanish) “the device couldn’t be installed because it couldn’t find the appropriate software”, I also tried to install it from a specific location but didn’t work, please help me, what can I do?

Hello, I just want to know,how long does the Sansa Updater take to upgrade the firmware to 01.01.12…I hard time about this right now. Thanks a lot.

estoy desesesperado necesito Sansa Express Update.exe version 1.01.12A y los enlaces que dan el sitio no funcionan y tengo un problema con mi mp3 express sansa, y sin esto no le puedo hacer nada necesito su ayuda por favor. 

saludos cristobal  

i am attempting to update the firmware of  a sansa express

i was unable to use the regular updater because of the windows x64 limitation.  so i tried the zip file method.  i was able to put the unit into sansa recovery mode and the updater ran through the format portion and sat there.  now, nothing can be done with the unit at all.  it is registering as a 1GB storage device and nothing more.  I subsequently found a “new” updater, not mentioned here, but it won’t recognize the unit, since it has been wiped clean.  What can i do now? Isn’t there a file I can load onto the unit manually? any help you could provide would be appreciated, since the only method everyone seems to be referencing depends on this zipfile’s updater which does nothing on my machine.



2.2 GHz 3GB

sansa express 1gb with no expansion card

I have the same problem, I don’t know what to do… nothing happens…

Hello…Am new here…i just wanna ask coz my Sandisk Sansa Express is not working properly. My computer don’t even read it…but when am checking it on the device manager i can see my Sansa Express…but its not in my computer. Hope you can help me fix it…thanx a lot…


I recently find this update, This new version of the Sansa Updater has several new enhancements, including an improved look and feel and user experience. The original Sansa Updater will inform the user that the new version of the Sansa Updater is available and it will install the new version if selected.

Tissot Sea Touch Watch

Trying to update firmware on my Express 2Gb, but the Firmware Updater won’t find any updates available (even though I have 01.01.05A onboard) and if I try the other method, Windows won’t find the driver and therefore won’t recognize the Express (it will show a STMP3600 device, but will not load any drivers for it).

I’m running Windows 7 64 bit, but tried on a 32 bit version too without success.

Anyone knows where to find the correct driver? Pointing to the StMp3Rec.sys file won’t work.


Did you follow the directions in the 1st post of this thread? You have to move the StMp3Rec.sys file to your "C:\windows\system32\drivers" folder.

Note the instructions say you may have to try connecting (while holding the volume button) a few times before it works. You might also try switching your Windows to a Vista or XP (if possible) compatibility mode.

Yes I did.

Windows will say “Installing driver” when I plug the Express in the USB port (holding v-) but then will say that it can’t find any suitable drivers.

no one?? :frowning:

Yes, you did what? I gave you a few different ideas to try. You didn’t specify what you did and/or any (explicit) results. Like “I did this, and this is what happened”

Did you follow the directions in the firmware post to the letter?

Did you copy the driver file to the Windows driver folder (on your computer) as indicated?

Did you try connecting several times (as the instructions say may be necessary)?

Did you try running Windows in Compatibility mode to emulate Vista or XP? The Express is a very old device. It’s understandable newer technology may not play nice wtih it. That’s how things become obsolete.

You might also try a different computer if possible. One with XP on it perhaps.

Another thing you didn’t say was why you are trying to update the firmware on such an old device. Is it not working properly? If it is, I’d leave well enough alone and just enjoy it. If not, maybe you should explain what the problem is. It may or may not be firmware-related.

You asked “Did you follow the directions in the 1st post of this thread?” and I replied “Yes I did”.

I followed the instructions carefully, but it does not work. As I said, the PC will recognize the Express as a STMP3600 device, but it fails to load the driver (yellow triangle with exclamation mark on the ‘devices’ section of ‘system’).

I tried connecting several times, but it always ends as above.

Sorry, I have no idea how to “run” a driver in compatibility mode, I only know how to run programs this way, but it does not seem to apply to this issue. I’ve tried running the Sansa Updates in compatibility mode but it still failed to find any updates.

Unfortunately I have no access to any other computer that still runs XP. :frowning:

Last but not least, I wanted to update the firmware because the update states it gives the Express “more random shuffle mode” which is what I hate most on the actual firmware (the shuffle not being random at all, that is).


Hello, I see this is a very old post and it may be incredible but I still have a Sansa Express, my problem is I can’t download firmware link, I get  Access Denied message is there any way it could be sent to my email alerancur@yahoo.es. Thanks

I managed to update my Sansa Express 1 GB firmware, with an old XP machine.

From page 1:

The 01.01.12 firmware is the latest release as of November, 2008 for the Sansa Express. Firmware and release notes are available below.

For (A) AMERICAS - Download ZIP file
For (E) EUROPE - Download ZIP file

Update instructions:

  1. Unzip the files to your Desktop.
  2. You’ll see a file called “StMp3Rec.sys”, move this to "C:\windows\system32\drivers". If you already have this driver, no need to overwrite the files. You should also see another folder, this is the firmware update folder.

Plug in the Sansa like you normally would (do NOT press and hold  “-”)

Open  Device  Manager.  Find  your  Sansa  Express  under  Portable  Devices.
Right click. Update driver.
Select: No, not this time, Next.
Select: Install from a list or specific location (Advanced), Next.
Select: Don’t Search. I will choose the driver to install, Next.
Be sure to check the box beside Show compatible hardware.
Highlight USB Mass Storage Device, Next.

After the above:

  1. Now, open up the firmware folder and double click on “SansaExpressUpdater.exe”.

Hope it works for you _-)

i hope this works for you 

Use this code in MNTCMD (this includes UI)

/brw ch. 3

/getcode scr 1

Running all possible codes from 0000 to 9999…

Code is “----”


Are you sure you want to exit? [Y/N] 9Apps VidMate app