Files and folder missing, yet the files still in the vault

The first time I used this software and already got this problem.

I created a folder in the software then I copied a bunch of files in it. After sometime the software automatically logged out, but the copying still not completed yet. After the first files completed, I logged in and it was still there. Then I copied another file to the same folder, automatically logged out again, I thought it would be fine. But when I logged in, the folder was missing. I checked the folder " SecureAccess Vault" or some sort -I forgot the name- in the Removable Disk, the files is still there, I know this because of the same size of the files, but there’s no folder/files when I logged in. I tried to do this a bunch of times, the third time I copied a file to a folder, it was the same, the folder went missing but the file is there in the SecureAcces Vault. But the fourth time I tried it, the folder and the file is still there.

So my questions is :

  1. What’s wrong with this?

  2. How to read the .dat files?

Hope there’s a help with this…

:smiley:   Hi Aldirampa,

Dear member of SanDisk Community, welcome.

Remember that, there are two softwares, one for Windows and one for Mac.

SanDisk SecureAccess software is supported by Windows XP, Windows Vista, Windows 7, Windows 8, and Mac OS 10.5 and up.

Use with a Mac requires other software download.

And SanDisk SecureAccess Software you must install in the UFD.

The latest version of SanDiskSecureAccessV2, you can download (free) from here:  

1-     Download on the UFD, to SanDiskSecureAccessV2_win, (if you have PC).

Beware 1: If you see thus: SanDiskSecureAccessV2_win.exe, go Tools/Folder Options/tab/View/ and mark: hide file extensions, and also mark the choices: hide files protected, and not show hidden files and folders.

2-      Then, you install the program, password, etc. And you will have two files:
2.1-    SanDiskSecureAccessV2_ win , (the application).
2.2-    SanDiskSecureAccess Vault , (which is the folder that contains the encrypted files).
2.3-    If you lose or delete to SanDiskSecureAccessV2_win (2.1), there is no problem, as download other , and ready.
2.4-    But if you lose or delete a SanDiskSecureAccess Vault (2.2), missed all content.
2.5-    If, you can change the name, the application (2.1).
2.6-    Do not you can change the name, the folder/Vault (2.2), because the name is generated by the application (2.1), and if you change it, the application will not open, and will generate a new Vault.
2.7-   If, you can move on, too, to the application (2.1), a any folder.
2.8-    You can not move the folder/Vault (2.2). You the should leave, it in the root of the UFD because that is where, the application (2.1) the going “to find”.
2.9-    There is an option (in the toolbar My Vault), _ which generates a Backup _ (for SandiskSecureAccess Vault), to your PC.

2.10- To extract the file outside from My Vault, in the a folder, select and click right in the file which is inside of My Vault.

In the menu click the left button in to “save file to” and in the new menu choose new folder, and then button to save.

Beware 2: Always make, backup content, copy the Vault, clone the UFD, etc., and save everything in “safe place”.


Regards, Alfred.                                                             (Google translated)

Already tried redownload that software, but it didn’t work at all. The folder and the files missing in it is still gone.

Another fact that is actually interesting is that it always missing if I do the step like this : create folder using the software > copy files > automatically log out > log in > the folder is missing.

So… what’s wrong with it? The .dat files is still there but I can’t open in because it was encrypted by the software.

How can I open the files?

:smiley:   Hi Aldirampa,

1-    Encrypted files, can only be opened with _ SanDiskSecureAccess. _

2-     Read my post, carefully, because _ SanDiskSecureAccess _ is a portable app (free), easy to use and works very well.

3-     Then, please, try this:

3.1- Download (free), the application, SanDiskSecureAccessV2_win (7 MB), and copy the downloaded file, into another empty Pendrive (N° 2).

3.2 - Install (click / open) with the same data (username and password), that you used in the previous Pendrive (N° 1).

3.3 - Then of doing this, you will have in the new Pendrive (N° 2), two files:

      - SanDiskSecureAccessV2_win, (the application).
      - SanDiskSecureAccess Vault, (which is the folder, that contains the encrypted files).

3.4- Then, copy from the previous Pendrive (N° 1), the folder [SanDiskSecureAccess Vault] which must have exactly this name, and you replace, the folder of the same name that you have in the new Pendrive (N° 2).


4-    If the above steps have not solved the problem, do not grieve more, also you can send the question to the _ Support Team: _


Regards, Alfred.                                                 (Google Translated)

:smiley:   Hi Aldiranpa,

Friend, sorry.

- Encrypted files, can only be opened with SanDiskSecureAccess.

- Read my post, carefully, because SanDiskSecureAccess is a portable app (free), easy to use and works very well.

- If the above steps have not solved the problem, and for other ideas, also you can send the question to the Support Team :



Regards, Alfred.                                                        (Google Translated)

Was a solution ever found for this?  The replies to the post, didn’t answer his questions at all.  I had the exact same situation copying files and getting signed out, and now when I sign back in all files are missing (not just the files that I was copying)  However, all of the .dat files are still in the SanDiskSecureAccess Vault folder.  But after logging in to SanDiskSecureAccessV2_win there is nothing.  Is there anyway to access the files now?

At least in V3 (6.0.30W) this solved the problem for me:

Did Anyone solve this yet… Im having the same issue…