Failure reading the filesystems file (err=1)

Hi all!

I’ve connected my USB stick to my work computer today, on which my employer has put a system on that does not allow to copy data on USBs. This has been done through the entire organization. However, after connecting the USB stick I have managed to put in the password and enter my files through the SanDiskSecureAccess and open a word document. Still, after closing it, i couldn’t get back in and I left it as it was thinking it might me the new security system. After i got back home, I tried to connect it to my personal computer (I have a MAC vs a Windows one at the office) and after putting in the password I get the following error: **“Failure reading the filesystems file (err=1)” - see print screen **and can’t access my files despit they are still there. I also installed again SanDiskSecureAccessV3_mac, but i still get the same error.

I also used MAC’s Disk Utility and made a first aid, but everything came out all right and the error is still there.

Could you please help? How gen I get to my files/how can I get back my files?

Hope somebody can sort this thing out for me…

Many thanks!

This is exactly the same issue I have.

“alxrotar”, have you found a solution maybe?