Extreme 32GB USB not appearing in Boot Menu

Hey Guys,

I’m currently on my 2nd SanDisk Extreme USB 32GB as the first one turned out to be a fixed disk rather than a removable one, so I purchased another hoping it would be removable which it was. Unfortuantely I cannot for the life of me get the device to be reconized as a boot device (or even just regonized in the BIOS) on my X220T and T420 Lenovo laptops. I have a trancend USB and SanDisk Ultra 32GB USB which both work just fine. Can anyone help me with this? 


Are the laptops running Windows 8?  And is the DIOS configured to support UEFI devices?

No the laptops are running Windows 7 Enterprise and yes the BIOS is set to UEFI and Legacy

Is the drive formatted and if so what format?

Tried using FAT32 and NTFS, used both windows partition manager, gParted, and diskpart for formatting.

And regardless of format it doesn’t show!  Weird.  Did you repartition it by chance?

I Think this may help you. I never thought to change the boot order of the HD’s. http://www.tomshardware.com/forum/329871-30-bootable-windows-install-stick-detected-boot-device Good Luck !

Re: Ed I tried partitioning, using automated tools such as Windows USB tool, tools I’ve seen you recommend for linux, pendrivelinux, Ubuntu whole disk installer etc. Nothing seems to get it appearing on either the X220T or the T420 Lenovo. Unfortuantely the only other deivce I have is a Surface Pro so I cant check if it’s compaitable with other machines.

Re: Newatthis. I don’t arrange the boot order cause I’m going straight to the boot menu options and the drive doesn’t appear on the list (and subsequently wont be affected by boot priority)

Have you made the drive bootable?  If so what did you use?  Is the partition on the drive marked as Active?

Hi, same problem here

Laptop : t520

Stick: Sandisk Extreme 16 GB

Disk is not visible in boot menu. I have tried USB drive from different vendor, all working. I have tried the disk with different laptop, all booted correctly. I have found many users with this problem(sandisk + thinkpad).

I have tried to complete repartion the drive using diskpart, main partition is FAT32 and active. The “Boot Disk” flag is set to “no”, but my other flash drive is also set to “no” and it is working just fine.

Is there a possiblity there is some hidden partition windows is not able to see ? I heard windows systems are sometime having a hard time working with multiple partitions on a flash drive

Disk is not visible in boot menu.

Boot menu!!  Windows boot menu?  grub4dos boot menu?  grub2 boot menu? rEFInd boot menu?  ???

Did you modify the Windows EFI/BCD menu’s to boot the drive? 

Did you modify the system’s BIOS to boot the USB drive before the hard drive?

What did you use to make the USB drive bootable?  Personally I recpmmend Easy2Boot.  And what are you trying to boot on the USB drive?

"It is UEFI boot menu.

Boot order is set to USB drive first, but that doesnt matter since I am selecting the boot device manually ( the USB drive is not even visible in the menu, other devices are visible and bootable, including other flash drives).

“Did you modify the Windows EFI/BCD menu’s to boot the drive?” other flash drives are booting OK and I am running stock UEFI settings, this should be OK

“What did you use to make the USB drive bootable?”

Universal-USB-Installer. I have also tried the mentioned E2B, this time with NTFS formatting and UEFI is still not able to find the drive ( it is visible in Windows and working correctly).

I think the focus should be on the issue that the UEFI is not even able to see the USB drive.  Is there any way to troubleshoot this ?

Did you turn off the BIOS’s Secure Boot option?

To boot on EFI the drive needs the 1st partition to be FAT not NTFS.