Expresscache 1.3.0 install/uninstall error

I uninstalled Expresscache 1.3.0, but when I try & re-install, it trys to uninstall again, gets to 15% & then fails with error 1605 (see attached image). I’ve also tried re-installing 1.2.1 & updating, but it fails with the same error.

The original installation of 1.3.0 was done via the update function in Expresscache.

How do I stop this error/completely remove previous versions so I can re-install 1.3.0?

have you tried uninstalling and deleting everything in the temp folder? see post linked below

Removing temp files doesn’t solve this uninstall issue, neither removing the expresscache driver manually from the device manager (by unhiding non-pnp stuff).

Just tried removing all temp files (there was an ExpressCache folder), but it hasn’t fixed it. Still failing with error code 1605…

Even though it’s uninstalled, it’s still showing in the start menu & the program files (x86) folder.

open regedit and search for condusiv and sandisk and delete all the reg keys then reboot and see if you still see the same issue. 

Try this:

look under: C:\Program Files\Condusiv Technologies\ExpressCache

if it is empty:

  1. Reboot your system.

  2. Go under:

   for 64bit system:   C:\Program Files (x86)\SanDisk\

   for 32bit system:   C:\Program Files\SanDisk\

  1. Delete the ExpressCache folder

  2. open the registry: run regedit.exe

  3. Go to


  1. Delete ExpressCache

  2. Run ExpressCacheSetup. It should install.

if it not empty:

  1. Open Programs and Features

  2. Uninstall ExpressCache (not ExpressCacheApp)

  3. Now go to step 1. (reboot your system)

Let me know which one worked for you.

I deleted the directory in program files, then manually searched/deleted all sandisk & condusiv references in the registry and it’s installed again now. Will keep an eye on it to make sure it’s working OK.

Appreciate the help!!

Same here, needed to remove everything by hand. Also, a working 1.3.0 uninstall forgets to remove the ExpressCache Storage Filter Driver under non pnp drivers.

Hey, I’ve tried your solution but I can’t uninstall it, it tells me to verify if I the the right to uninstall it, how did you manage to uninstall it?

I have an asus ux32a ultrabook.

I recently cloned my HDD to a same size SSD. Used the special ssd specific clone method. 

In partition manager I can no longer see the 24GB SSD.

I seem to have intel rapid start program installed but cant see express cache in installed programes.

Can I un install intel rapid start and run the express cache uninstall.bat?

How do I make the 24 GB ssd appear as a useable drive?

expresscache will not cache anything is the system drive is an SSD. It will ignore all data stored on SSD since there would be no performance gain when caching data that is already on an SSD. 

For your other questions about getting the 24GB ssd to show as a drive that is a better question for Asus. i would recommend you contact them as your product is OEM and all support is handled by the host manufacturer.