Can not uninstall, and can not re-install


I have a non-functional installation of Express Cache 1.3.2  on my Windows 7 professional 32bit. I want to uninstall complete as I wan to go for a real SSD.

  • When I start the Expresscache App, It says: “ExpressCache can not launch. Try using the original user account for the first time”. (There is only one account on this machine)
  • When I strart “Uninstall” from the start menu / sandisk / expresscache, it fails at the point “removing drivers” with an error code 1603
  • When I uninstall ExpressCacheApp manually from the system control, it happens the same.
  • When I uninstall ExpressCache (Condusiv) manually from the system control, nothing happens
  • When I manually launch the ExpressCache (Condusiv) Install Shield Wizard, which is ExpressCache.msi, using the uninstall option, it says “The wizard was interrupted before ExpressCache could be completely installed. Your system has not been modified”

What I also tried before:

  • removed security software
  • tried the “ec-win10-cleaunup.exe”. This results in a 0x0000007B bluescreen error on next start. So I must rebuild the “last known functional system”
  • made unused drivers visible in the device manager, and set the “Express Cache Storage Filter Driver” service to disabled. Result: 0x0000007B bluescreen error 
  • removed the ExpressCache App manually by killing all registery keys. Result: Express cache drivers are still active
  • removed the ExpressCache drivers by killing all related registery keys. Result: 0x0000007B bluescreen error
  • tried to uninstall in safe mode

The point is, I have the two Express Cache drivers deep in my system,

  • excfs.sys (ExpressCache File System Filter Driver) file driver
  • excsd.sys (ExpressCache Storage Filter Driver) kernel driver

that will not uninstall. Missing these, results in the 0x0000007B bluescreen error.

However, in safe mode excfs is not running.

I tried to manually remove nearly all Express Cache software. So I could re-install new. But the installer fails at the step of “installing drivers”. Sure, the old drivers are still running and can not be overwritten.

Any idea how to perform a complete uninstall or clean re-install and then un-install?

Thank you,


I also tried Microsofts Program Install and Uninstall Diagcab tool, which may help remove failed installations. This had also no result.

Today I removed the excsd kernel driver. This is how to:

I opened regedit.exe and went to the key


Found this one by searching for “excsd” (you have to enable keys, values and also DATA to find). We have the key “UpperFilters” here, with the value “excsd, PartMgr” (2 lines). Removed the excsd line. Reboot (no bluescreen!)

Step 2:

Goto the key


When I removed this key previously, I got these bluescreen on reboot.

Click on the value “Start” and change from 0 (load on boot) to 4 (disabled).

Reboot (no bluescreen!)

The excsd kernel driver service is now still present, but not started.

Step 3:

Now I removed the


subfolder completely.

Reboot (no bluescreen!)

excsd service is gone.

Step 4: Now I’m going to remove anything related to excsd, excsf, ExpressCache or Condusiv step by step from my registry, performing a manual uninstall this way.

Step 5: Install my new SSD and enjoy.