Error ... not valid Win32 application

When I double click the RunSanDiskSecureAccess_Win.exe  (a download gave me a slight different file - RunSanDiskSecureAccess-Win.exe  (with a dash) I get an error message     F:\RunSanDisk… is not a valid Win32 application.

Both files give the same error message.

I copied the file to my PC and it started to open the vault, but says I need to run this on the USB drive. so it seems the file is okay when run on my PC, but not when I try to run from the USB drive.

Any ideas?

Any ideas?

Yes, you’re probably running it on a Windows 7 64bit machine and it needs to be set to run, on the USB drive, in Compatibility Mode.  Try Vista SP2.

Hi. What OS are you using? Try to check if your system is indeed 32 or 64 bit. 

Good luck. 

I have exactly the same problem.

I am using 32 bit Vista. When  I tried to run program within USB (  RunSanDiskSecureAccess_Win.exe ), " is not a valid Win32 application" message occurs.

I think that it’s not about 32 bit or 64 bit because when you copied into desktop, it runs. 

Is it show a problem in USB Flash Drive? (It’s too slow, every time it freezes while I clicked it.) 

RunSanDiskSecureAccess_Win.exe

I suspect your security app is limiting things running on removable drives.

I’m having the exact same problem, I have a blade 32GB, running Windows vista 32bit OS. I also have the SecureAccess software running fine on other SanDisk USB drives, tried copying from there to the Blade, and got the same error.

*Solved, it’s a windows DLL problem.

Care to expand on that?

Hello,

For what it’s worth, I had the same problem with Win Vista 32 and I “solved” it by deleting the autorun.inf file on the USB key.

After deletion, you need to remove the key and insert it again.

Of course, save the autorun.inf file somewhere else before just in case.

Yves

Above did not work for me. I have EXACTLY the same problem as SU. Can I fix - easily? Or do I return it as faulty.

You’re running Vista 32-bit also?

Yes.

Too late. I am returning it as faulty. Have wasted too much valuable time already. Pity as the secure bit appealed. But not if it is going to cause problems. From other posts I see there are other problems too. I shall go for a simpler drive.

Not having Vista I suspect SecureAccess needs to be run in a Windows Compatibility mode.  At least it does on Windows 7 64-bit. Vista SP2 mode no less. 

My Sandisk Cruzer 8 GB was fine when I used SanDiskSecureAccessManager to backup my data last week. Today when I tried to backup, I got a message of “Update the RunSanDiskSecureAccess-win.exe?”.  Of course I click “Yes”.  After the update finished, I try to backup and got an error message of " J:\RunSanDiskSecureAccess-win.exe is not a valid Win32 application."

I checked my computer which runs Vista 32 bits. I also delete the  autorun.inf  file on the USB key follow the suggestion of ‘ysagnier’ without success.  

Does anyone solve this problem?  Would you please kindly share the solution? 

Or if there is no solution, I would like to delete RunSanDiskSecureAccess-win.exe, RunClubSanDisk.exe, MyVaults etc from this Cruzer, do I have to reformat this USB drive before I can use it?

Thank you very much in advance for your help. 

hmmmmm  I am not aware of any update to SecureAccess.  And Windows systems don’t use the autorun.inf file since Windows XP SP3 so there is no need to delete it.  Might you have a virus?

You can download the official app from here: http://kb.sandisk.com/app/answers/detail/a_id/2399/session/L2F2LzEvdGltZS8xMzYyNDY4NjMwL3NpZC9vd0I2d25rbA%3D%3D just to be on the save side.

If you want to remove the files and folders on the drive you certainly can, no need to format it.