e260 V1 doesn't want to charge

I’ve searched a lot of threads on here about charging problems, and I still can’t seem to get this solved. 

If I plug the player into the USB port when the player is off, it stays off unless I press the power button.  Then it starts up, and the battery indicator shows a fully charged battery.  The display says “Connected” and the little arrows go back and forth, but there’s no lightning bolt by the battery indicator – to be expected if the battery really was fully charged. 

However, if I turn the player on before plugging it in, the battery indicator shows (right now) about 1/3 full.  Then when I plug it in, the battery indicator jumps up to about 3/4 full, but still no lightning bolt indicating charging is going on.  If I leave the player connected like this, the screen stays lit the whole time but the battery indicator never moves, even after several hours.  As far as I can tell, no charging is going on.

Here are some of the things I’ve tried:

  1. Remove battery and clean terminals before reinstalling.  This seemed to help a little.  When I first started having trouble with the player a couple of days ago, the battery seemed almost dead.  Cleaning the terminals got it back up to where it is now (about 1/3).

  2. Reset the player by holding down the power button.  I’ve done this lots of times.

  3. Connect to a USB port on the back of the desktop computer for more power.

  4. Update the firmware to the latest version.

  5. Roll back the firmware to the second most recent version.

After the last step (rolling back the firmware), an interesting thing happened.  Now when I plug in the USB connection, the lightning bolt appears next to the battery for about half a second, then disappears.  Other than that, nothing has changed and it still doesn’t seem to be charging.

This is my wife’s player, and she sometimes goes for months without using it.  It probably hasn’t been through more than 3 or 4 charging cycles in its entire life, though I know she has let the battery get really low before this.  From what I’ve read in other posts, it’s possible the player’s charging circuitry is shot.  Other than buying a new battery, is there any way to be sure?  Any other ideas?  Thanks in advance.

Another possibility would be a bad USB cable. Maybe the data pins/circuits are connecting, but not the charging ones.

Is the device end of the Sansa cable a proprietary configuration?  I’ve got a cable that came with my Creative Zen player at home that looks pretty similar.

Yes, it is. You never want to use a cable designed for another player with your Sansa; especially an iPod one. While many are similar and some can even be forced in, the power is shunted through different pins and can literally fry your player.

SanDisk mp3 cables are relatively inexpensive and readily available. You can get them on Amazon.com or the Sansa Store here.

I am having the exact same problem, half-second charge lightning bolt then no further charging shown.  The e260 is have is the second one, newest is a referb.   Battery looks okay.   Did anything ever get resolved on making player charge correctly?

Haphazard charge indicator diaplays are a sign of a tired battery.  If there’s a change in the behavior after cleaning the terminals on the battery module, this also points to a module issue.

There are many sources for e200 battery modules, including Radio Shack in the US.  All you need is to Google “Sansa e200 battery” and you’ll be amazed at the choices.  Plenty of good prices too, most under $20.

Bob  :smileyvery-happy: