drivers for Sansa M240

I have used my sansa M240, which is in MSC mode in many computers before without any problems. i am now trying it in a new computer and it seems to have no drivers available. I thought that it didn’t need drivers, I’m running windows XP Professional. There doesn’t seem to be a download on sandisk’s website. What am i missing?

You need drivers wpdusb.sys and WudfRd.sys in your drivers folder. C:Windows/system32/drivers

Place the drivers in there but do not replace a newer version with an old one. Most likely you are missing WudfRd.sys

I had the same problem today. Luckily I went to the machine I know the sansa worked on and copied the drivers to get it working on my new machine. It also is XP Pro.  Good luck.

pls sent me tiz driver

Hello from Peru!

Actually i have the same problem with my mp3 player m240; but, i have -reinstalled the pc’s os, because, it was to slow… my sansa’s cd is broken, pls can you send me this driver…? you help me so much!

best regards…

Where can we find the drivers?  Are they available for download and/or purchase?  I am having the same problem!

Hi my computer is not recognising sansa please mail me the driver of m240 audio player

Do you have WMP 10 or higher? MP3 players set to operate in the MTP mode need WMP 10 or higher to be supported in XP.

Regarding on your concern try the following step on this link, it is just the same procedure with MSC;

http://kb.sandisk.com/app/answers/detail/a_id/42/kw/m200%20not%20detected%20on%20my%20computer/r_id/101834

Hope this help. :wink:

No drivers needed. Its either a missing or corrupt driver causing this if you are already set at MSC mode. Troubleshoot using the link above provided by keberloo or update the operating system’s Service Pack so that the drivers are added/repaired on your system.

MTP mode requires Windows Media Player 10 or 11 installed for it to work. Can be donwloaded here.

alguien que tenga los drivers

The m240 should be addressable as a flash drive. Desribe the type of trouble you are having, and we can help you!

Bob  :smileyvery-happy:

I plugged in mine into a Windows 7 and I also got an error the first time. I removed the usb connector and plugged it in after looking up how to fix it and viola! it worked.

Just replug it in. First time for some reason it hiccups and does not install.