Cruzer is "write protected" & can't reformat

Just bought Cruzer 16G and can’t write to it - “write protected” - also won’t allow me to reformat - “write protected” - won’t allow me to erase - “write protected” - all the instructions I’ve found don’t apply to WinVista. Tried using Disk Manager but the “format” command is greyed out & doesn’t work.  Wrote to SanDisk customer service & only got back a message to “use a WinXP computer” - I don’t have access to a WinXP computer. Why in the world would they sell a memory device that is write protected?

Apparently, Sandisk’s so-called “customer service” is refusing to tell me how to remove the write protect from my Cruzer. All they are willing to tell me is to use someone else’s XP computer to reformat it. I don’t have an XP computer and don’t have access to one. They have stopped answering my messages and refuse to help.

Older U3 devices lack support for Windows Vista and Windows 7.  The only way to remove the U3 software is via a Windows XP machine.  Support has told you the answer, you don’t want to accept it, but it’s the answer regardless, and complaining about it won’t change anything.

Libraries usually have machines with XP go to one of them. 

Worst case return the Cruzer to where you bought it and have them remove the software or refund your money. 

Hmmmm. Im not sure if this is an SSD but have you tried looking for a toggle switch? Its usually for write protection. try toggling it and reformat. See if it makes a difference.   

I took it to a PC shop & the guy tried a variety of different machines, incl XP, & couldn’t reformat.

I took it back to Radio Shack, told the whole story and their inhouse hacker tried everything he knew.

They were willing to trade me a new one & return that one as “defective”.

The guy at the PC shop had told me that he has never had this prob because he has never tried to use one without reformatting it right out of the box. He considers it the normal & neccessary “initialization”.

So, when I go the new one home the first thing I did was reformat. It works fine.

I do NOT accept the premise that SanDisk is blameless.

Thanks for the update rscott77092.  Happy to hear you got the problem resolved.

FWIW   I don’t agree with the guy at the pc shop, unless he buys his USB sticks off of eBay in which case I than do agree.  I’ve only formated a USB stick once, and that was to NTFS so I could backup files larger than 4 GB.  And I restored the U3 system folder, which I backed up before formating it, so U3 still works on it even.   All others have worked as soon as I plug them in.

Me toooooooooooooooooooooooooooooooooooo hate it sandisk so much **bleep**

What a useful and informative comment. Thank you so much for your contribution.