Cruzer Glide - cannot access ScanDisk Secure Access

Have documents in vault in disk.  Says “Powered by YuuWaa.”  When I access the vault I cannot move files, or delete or add new files.  Contacted ScanDisk chat helpline today.

 All I got after 30 minutes was “Sorry your disk is corrupted.”  I have not even used this disk since the time I stored the files and the last I checked a couple of months ago, it worked fine.  I even tried to open it in another computer - same problem.

So I sucked it up and decided to reformat the entire flash drive.  Can’t do that because it was it is write protected.  Changed registry key to unlock storage devices.  No luck.

It seems that the Scan Disk Access program is no allowing any changes to this disk.  I just want to get rid of this secure program and reformat the drive for regular use.

Please help.

Write protect is not a SecureAccess problem it is a chip problem in the Glide itself.  There is no fix for the problem, only a return to SanDisk for a free replacement.  Sorry.

I just hope that this is still under warranty so you could possibly ask for a replacement.