Cruzer Glide 64GB

I have a brand new Cruzer Glide 64 GB.  I was able to write about a dozen files to it.  Now when I try to use it I get a message that the disk is write protected.  I can find no way to remove the write protection.  I can not add any files to the drive, nor can I delete the existing files.  Any ideas anyone?  All it tells me to do is remove the write protection…  Time for a return?

 Time for a return?


3-year old Toshiba X770 Series laptop, Windows 7.

I bought this flash drive at Staples two days ago.  It shows up as a hard drive, not a USB.

Yesterday I tried to copy 3 GB of documents (.wpd, .doc, .txt), consisting of 35,000 files from my C: drive to the USB.

The speed was in KB/sec.  I cancelled out after half an hour.

I tried it in three different ports, 2.0 and 3.0, and then on my XP desktop.  The results were the same.

This morning I downloaded a USB 3.0 driver from Toshiba; it makes no difference.

There is no .exe file, but I “possibly” could have deleted it (someone told me to do that if I didn’t want an auto behavior)

I optimized for documents, but it made no difference.

This is the first time I’ve copied the full document folder to a USB.  (Before this, the full Documents folder was on my desktop, with only a portion of it on the laptop.)

I don’t know if this is the Flash or if it’s my computer. I do know that there are forum threads devoted to extreme slowness of the Sandisk 64 in particular.

I got the Documents folder copied onto a WD external HD, and that also seemed slower than it should be, but not nearly as slow as the flash drive.

!.  How can I isolate the problem?  2.  And hopefully fix the problem?

Is the USB device configured in Win 7 for Performance or Quick Removal?

Is your security app set to test everything being written to a removable device?

Is the laptop running on batteries when copying or plugged in?