Cruzer Glide 4 GB

I tried installing the Cruzer Glide 4 GB on my HP personal computer running Windows 7. It recognizes the flash drive when inserted into the usb drive but always says there is no software or driver installed. Your website states that no driver is needed, and I should be able to simply drag and drop files to the usb drive. However, that doesn’t work or I am not doing something correctly. Dialog box just keeps saying there is no driver, goes online to try to find one and is unsuccessful.  I have run the troubleshooter with always the same result…no driver is installed. I have no idea what to try next or what I am doing wrong. Help!

I bought four, yes four, Cruzer Glide 8GB at Staples a couple weeks ago on a sale.  I was going to load them with my audio files and give them to friends.

But my Windows 7 PC does not recognize the USB is even there at all with RealPlayer or Windows Media Player.  So I am going to take them back to Staples and


I have looked around on this forum and find that all the fixes are for geeks who love to lose time while making money for SanDisk.

Hopefully you find a brand that you can work with.

BTW The most common fix is simply disabling an app running in the background.  Hardly a geek thing.  Maybe a friend can do it for you.

Since Sandisk, solely rely on Windows drivers, there are pointers that needed to be followed here. 

  1. OS needs to be legit.

  2. Make sure that you have the latest Windows Updates on.

  3. Try Safe mode too.