SanDisk Cruzer Glide 16GB and 64GB not work on my HP DV6 Laptop with Windows 7

I can not get my SanDisk Cruzer Glide 16GB or 64GB to work on my HP DV6 Laptop with Windows 7.  The same flash drives work in two other computer I have tried them, but NOT in my HP Laptop.  When I plug them in it take about 60+ seconds before they appear in the “My Computer” display.  If I double click on the “Removable Disk Icon (I:)”, after about 60+ seconds, as a gray bar moves across the second line at the top, “This Folder is Empty” finally displays.  If I Click “New Folder” an error comes up stating “Item Not Found”, “Could not find this item”, “This is no longer located in Computer, Verify the item’s location and try again”.  It appears about like a DVD drive with no disk inserted.

Disk Management shows a Removable Disk at I: with “No Media”.

Again these Flash Drives work fine on other computers, and do contain files.

My other 16GB flash drive (not SanDisk) works fine on the same computer.

SD card reader with SanDisk SDHC cards work fine in the same USN ports.

Does anyone know what I need to do to fix this problem?


12-04-2012  Additional Information

I found out today, that if either of my SanDisk Flash drives (16GB or 64GB) are plugged into the USB port BEFORE I start up the computer from a total shut down they come up in a totally normal readable state.  I can read or write to the flash drives with no problem.  However, if I Eject / Safely Remove the flash drive, then reinsert the flash drive the state is in the unusable form as described in the paragraphs at the top.

If instead of doing a complete shut down I only do a Restart the flash drive stays in the unread / unusable state as described in the first paragraphs.

A complete power up from a full shut down, with the flash drive already in the USB port, is the ONLY way I have been able to get the SanDisk Flash Drive in a usable state on my Windows 7 64 bit HP DV6 Laptop.

I thought the 16GB flash drive had worked on this computer in previous weeks, but I can’t swear to it.  The 64GB flash drive was a Black Friday purchase, so wasn’t tried earlier.

Thanks for the update.

Windows, XP, 7, 32-bit, 64-bit is notorious with assigning and reassigning the same USB drive letters.  I suspect you have such a problem.  When the pc boots, and recognizes the USB drives try manually reassigning them a different drive letter.   Something like U, for USB drive, or R, for Removable, X, for extra, etc.  But something down the drive letter chain.  See if that helps.

Thanks. But is there a way for users to manually download and install the driver in this case?

Re-Sandisk Cruzer 16GB flash drive, I have a similar problem in that on my desktop pc which I  use windows 64 bit 2003 server that the flash drive was shown but when I opened no files was present.

Like in your information If I Click “New Folder” an error comes up stating “Item Not Found”, “Could not find this item”, "This is no longer located in Computer, Verify the item’s location and try again connected, i know that i had a file saved on the drive and after trying many options none worked.

On an after thought I connected the drive to my laptop which has windows xp 32bit, the dirve was seen in my computer and could open the files, I then checked the properties of the drive and it was FAT32 file system.

The only conclusion was to re-format the drive on my laptop and change the file system to NTFS this I did and when connected to desktop the dirve was seen in my computer and could write and see the flles, as NTFS uses 83mB of the total size I then changed it back to FAT32 and was still seen in my computer on the desktop.

Method to change the file system on the flash drive:-

Connect the drive to the usb port, open my computer, locate the drive which can be seen as i.e SANDISK(E), right hand click on the drive, scroll down to format, displayed in the window is File System which is shown as FAT32, click on the down arrow and NTFS is shown as well, select NTFS then click on start, when complete another window will open displaying format complete.

Check with your 64bit laptop ie Windows 7 and you should see the drive in my computer.

Hope this is useful.

Have had a similar problem with flash card on my desktop PC which uses windows 64 Bit 2003 server software, my other flash cards operate with no problem. I then tried the flash card on my old laptop with windows XP Bit and the drive worked, I finally decided to format it and tried it again on my the result was still the same in that was still not recognized.

I reconnected the drive onto my laptop and then decided to change the file system from FAT32 to NTFS, method how to do this:-

connect the flash drive to any USB port, open ‘My Computer’, on the section ‘Devices and Removable Storage’ right had click on the flash drive named i.e SANDISK(E:), scroll down to format and click on format, this opens another window showing the information of the drive, click on the down arrow on file system and this will show NTFS and FAT32, change it to NTFS then click on the start tab another window will show  'Format will erase all data then click OK this will format in NTFS.

Then when finished reconnect to your windows 7 pc and the drive will be seen in my computer, and then repeat the same as done on the windows xp 32 bit and reformat in FAT32, I found after doing this the flash drive operated correctly.

Has there been any update on this, I’m running into the exact same problem as the original poster, and renaming the drive letter does not fix it. I should point out that every other flash drive (other than the 2 8GB Cruzers I have) work fine. So it is not an issue with the drive, the USB controller or the drive letter. It must be something specific to the driver and how it interacts with the HP DV6. running Win7x64

Have you seen this post? Do you have any of the listed apps/programs running?

I had the same issue with sandisk cruzer glide. I have a solution that worked for me but I had to use linux to fix it. Linux was able to recognize it but said it had a bad superblock or was corrupted. I used fdisk and created a dos file system, then creating a new primary partition and making it partition number 1. Just accept the default sectors, keep pressing enter. after that you need to write the partition table by pressing w. Now that we are on the linux command line again type in mkdosfs /dev/sdb. Assuming of course your sandisk is /dev/sdb. It will take a while for it to format. But it fixed my problem. Hope this helps you guys. :wink:

I have a solution too but its kind of  sketchy. First off, I tried it on windows 10 and it beeped at me. I plugged it in a Linux System and tried to mount it; It said it was wrong fs type, bad option, bad superblock on /dev/sdb. I used fdisk on linux. I used fdisk and pressed ‘o’ to created a new dos partition table, then I pressed ‘n’ to create a new partition. I made it the primary partition and then made it the first partition. When it asked for the block size, I just kept hitting enter for the defaults. then I hit ‘w’ to write out the partition table. After that I typed in mkdosfs /dev/sdb and it formatted it. But it didn’t totally work…HOWEVER. When I plugged it back into Windows 10 it recognized it and asked for me to format it. I formatted it, and POOF!!! problem solved, worked on both linux and windows 10!