Cruzer Glide 32 GB Just circles can't get in?

I have my cousins Cruzer Glide 32 GB, I try to access it and it just shows it circling. I downloaded winusb.diagcab and it seems to run forever saying unlocking (and something else), but never seems to end? 

Is there any help in getting into this drive, how long should winusb take (I wonder) it certainly seems to tie the computer up. I am using windows 10 with plenty of memory and ram.  I was thinking SanDisk may have another program?

The minute you click on it, it starts to circle. I tried going to to the Command prompt, does not seem to be doing much there. No errors as of yet?

Any help would be appreciated


Have you tried a different USB port(s)? 

Have you tried a different pc? 

Have you tried a different OS? 

Have you tried accessing it with your security apps disabled?

Tried other ports, pc’s

Just have windows 10.

It recognizes it, but if I click on it, it just circles.

Same with the windows usb program, says, unlocking and ejecting

and  that is it.

Tried chckdsk from the prompt also

Happy to hear you’ve already tried chkdsk.  It was going to be my next suggestion.  You say Windows 10 recognizes it but can’t access it.  It could be your system’s security app(s) preventing foreign files from accessing your hard drive.

Try downloading a live Linux distro. Install it to a flash drive and boot the flash drive and see if it sees the files on the Glide.

Ubuntu will boot on EFI systems naturally other distros will require EFI’s Secure Access to be turned off.

I have installed this USB but due to some error in the process, I have got some of my data deleted. Then Data Recovery Dubai was the only one who helped in getting the lost data back. They helped me in getting them back intact.