Cruzer Blade 16GB stuck in READ-ONLY mode

Hi, I just bought this usb key 2 days ago. I was able to use it. Then I put a Linux OS on it. Everything worked fine. I decided to change the OS. I formated my usb key then I used Win32 Disk Imager. During the process I got a “media error” and it stopped at 72%.

Then I tried to format my usb key and it didn’t work.

Now when I plug my Cruzer, I’m getting a message saying that I need to format it. I click on format and then it says The disk is write protected…

Then each time I try to access to it, it says that I need to format and after I think you know the pattern…

So I looked on the forums for a solution. I tried the REGEDIT stuff, I tried other USB key on my PC to look if it would not be my usb port. I tried to unistall the driver then to plug back my cruzer. I tried to restart my PC in Safe Mode and then to try a format, didn’t work too.

I finally tried a Flash Drive tester and I used the full erase option. Didn’t work too.

Also when I want to format, it see the usb key as 2.9GB only and not 16GB.

Here a screen of the usb card:

And a other screen

E: is the letter linked to my Cruzer Blade. Drivers are well installed.

And with “Check Flash 1.16.2” it doesn’t detect my USB as a Media Storage. It only detect it as a “Physical Device”

And here’s when I try to full erase it

Red means Physical Drive Error.

Does someone know how to fix that ? I also tried to remove the usbstor.inf files on C:\Windows\inf

Thanks you,


So I looked on the forums for a solution.

Really Jason!!  You did this?

Then you must have seen all the postings that said that there is no fix for this problem and the only option is to return it for a free replacement.

BTW What Linux OS did you put on it? 

Well I put the usb key on the pc of my dad. Then when he tried to put his own sd card… The sd card got the same problem, now he’s mad as me…

Any help please… I tried to install ubuntu

he tried to put his own sd card… The sd card got the same problem

That is VERY strange loki318.  I have never heard of that happening before so I have no idea what could have caused the problem to spread to his sd card.  ubuntu wouldn’t have caused it.  Has he tried rebooting and then retrying his card?

Well, he has been able to format it without error messages.

Good to hear loki318.  If he can format it then his is writable.  As for yours, if you can’t format it, return it.

Thanks for the update.