Corrupt files ruined my shoot!

Hello.

I just finished a videoshoot where I used a Canon 7D together with a SanDisk Extreme CF card for close-up. The 16GB, 60 MB/s one. (And a Sony PMW EX-1 camera for the wide-angle, which had no problems what so ever.) I return to my desktop to copy the files to my computer for editing in my CS5 suite. I try to import the files, but find that only 2/3 of the files will import properly. 1/3 of the files are not recognized by Premiere, After Effects, VLC, MediaPlayer, QuickTime or any other software. I do a quick Google-search and find a few forums claiming that this is a typical SanDisk-problem - corrupted files. WTF??! Some forums also claims that at least 3% of the CF-cards is known to have problems like this. WTF - again??!

Did I just ruin my chances in the video-industry? I was supposed to deliver two camera angles of a well-known person in Norway, for use in a television show, but as you may understand 1/3 of my close-up shots are not working - they are corrupt.

Can you please tell me if this is a known issue. I may have to re evaluate the use of my 7D - because I believe you are supposed to be the worlds leading company when it comes to CF-cards - or am I mistaken?

And before you start bugging me with all the details - yes, I did copy the files correctly, I did have a full battery on my camera, I did check the original files, I do have a kick-ass machine and I do own some kick-ase  cameras - I did everything correctly. In fact I have been using computers and video-software since they became available for most people - a great many years now. And I find it very sad that I am not able to deliver what is asked of me after so many years - after spending so much money. And I can’t be bothered to send you files or CF-card - it is just not worth it.

I want an answer.

Is this a 7D-problem or a SanDisk-problem?!!

this could be an issue with the file allocation table. you can try formatting the card (if you are using windows 7 make sure and check quick format otherwise it will securely erase all the files and recovery will not be possible) and use data recovery software to recover the vids. if it recovers the vids and you have the same issue  then the files themselves are corrupt. 

if this is the issue you are not likely going to be able to repair the videos for use unfortunately. I would test the card with other cameras and using the computer to see if you see similar issues. try taking known good video files from your computer and copying them to the card using a card reader. fill the card to full capacity and see if all videos play normally once they are copied to the card. if you have other cameras you can try using the card in them as well shooting video and filling it to full capacity. if you don’t see any issues on these tests I would say the card is working normally and you may want to look at the 7d a little further to make sure it is not the root cause of the issue. 

For me, it’s not the camera or the memory cards, but Windows 7 - same symptoms.

Fortunately I still have a Windows XP computer, everything downloads perfectly there, then the added step of transferring to the Windows 7 computer.

Searching various forums for a good explanation/solution, none yet - various comments about problems with cards above 2GB - in fact, my only memory card that works through the card reader on my Windows 7 computer is 1GB.

Having fun finding all the things that worked on XP but not Win7…

looks like canon released a firmware that is suppose to fix this issue. here are the release notes and a link to the fimrware.

Canon 7D Firmware

Release Notes

Changes in this firmware: Firmware Version 1.2.5 incorporates the following improvements and fixes. 1. Fixed a rare phenomenon in which there were rare cases where movie files taken could not be opened when repeatedly shooting movies with specific CF cards. 2. Fixed a rare phenomenon in which there were cases where "Err 02" appeared when repeatedly shooting still images with specific CF cards. 3. Fixed a phenomenon that occurred when using high-capacity (32 GB or greater) CF cards: If either a CF card with only a little available space remaining or the battery was removed and then reinserted into the camera, and then the user attempted to start shooting movies immediately, shooting would stop. 4. Improved the writing/reading speeds when using UDMA 7-compatible CF cards. 5. Fixed a phenomenon that occurred when custom function C.Fn 4-1 was set to assign IS start to the AF stop button on the lens: When used with lenses that do not have an AF stop button, the IS function would not work. 6. Corrected some mistakes in the menu screens displayed in Arabic and Portuguese. (This applies to models in overseas markets. The models for the Japanese market do not display those languages.) The Version 1.2.5 firmware being released this time is for cameras with firmware up to Version 1.2.4. If the camera's firmware is already Version 1.2.5, it is not necessary to update the firmware. Note that cameras with the Version 1.2.5 firmware (and also Versions 1.2.0 through 1.2.4) cannot be downgraded to a previous firmware version (such as Version 1.1.0 or earlier).

When the 8 morning arrived URL=[http://www.sanjoseasianescort.com]San Jose Asian Escort[/URL] the Druids would give URL=[http://www.sanjoseasianescort.com]San Jose Asian Escorts[/URL] a piece of wood URL=[http://www.sanjoseasianescort.com]San Jose Escort[/URL] from their fires to each family,then they would take them home to start new cooking fires.These URL=[http://www.sanjoseasianescort.com]San Jose Escorts[/URL] fires would keep the homes warm and free from evil

in my own opinion its because of the cards. :frowning: sorry to hear your shoot was a mess.

I too have a Canon 7D but it already has firmware 1.2.5 and one of my SanDisk 8 GB CF cards has “died”, or at least it will not be recognized by either one of my two computers when I tried to download my shoot last month. It is an Ultra 30mb/s with a Ser # BI110713940B. It is the only CF card that I have had go bad on me. When I insert it into either of my two card adapters or directly into my Dell desktop’s discrete CF slot, neither my laptop nor desktop will even show it exists! Placing it into my Canon 7D shows similar issues- it just shows nothing is inserted into the CF loading slot so even if I wanted to try and reformat it, it won’t do anything.I have about 10 CF cards (5 are various types of SanDisk) at present and none of them have ever shown any problems. I would like to know if there is any software that can access my data, just to salvage it and then just chunk the card as I cannot trust it anymore. A replacement might be nice since it is approx only one year old.

Chrisjm77