CF Card failure - a bit different

My Sandisk Extreme Pro 16GB CF card is not being recognized by my camera. I shot today, uploaded the images to my computer and put the card back into the camera - my usual procedure. This time the camera returned an error message stating the card needed to be formatted, but then would not format the card because “the card is faulty”. I tried the card in my other camera and received the same error message. I placed the card back into the card reader and the computer recognizes the card. I’ve known cards to fail in camera and know how to attempt recovery of images, but I’ve never encountered this particular issue. I have four other Sandisk CF cards and these are performing as usual. Camera #1: Canon 5D-Mark II; Camera #2: Canon 5D. I’ve had the 16GB card for approximately 6 months. Any ideas?


I’m in exactly the same state. I have six Extreme Pro 16GB 90/MB/s cards and during a shoot last week one had exactly the same failure. No cameras will read the card, nor will any PC’s.

Am really unimpressed to see I’m not alone

1 Like

I have the same problem. My Sandisk Extreme Pro is not recognized by my EOS 7D neither the computer…

1 Like

I’m furious because I’ve lost 3 cards so far. They are all Sandisk 32 Gig cards. I shot with one and the same day my computer won’t recognize the card. Then I put it in my camera and it says that I need to format the card. So I can’t get video clips off the card now. I was working for a client so this is not cool. I was told not to fill up the card by a guy working at Calumet in Boston. Don’t you allthink that Sandisk should be responsible for getting our data back? Any tips on making sure cards don’t fail would be much appreciated. 

3 X 32GB cards have failed on me also. 

All 3 are Extreme 60MB/s UDMA are all now Extremely 0MB/s

Good news is, it’s “only” $1000 down the toilet.


1 Like

I’m in the same boat here, too.

32GB Extreme CF Card will not read or format in the camera or computer. Canon 7D, Windows 7 PC

Same here guys, I’m using Canon 5D mk II, 32GB.

I was looking info on the net when I found this forum, with this problem… Any one found how to solve this ??

It’s quite urgent since I have got a wedding to shoot this weekend.  

1 Like

Hi guys, 

I just wanted to give a short update of what I did.

I have put my card with an external card reader in the 3.0 USB port and waited at least 1 min, the adressbalk went green very slowly… Once completely green I clicked right mouse and waited again like 45 sec till popup showed up, then I have select format, again it took long till format tool opened. I deselected “fast formating” and clicked format, after like 10% the progress bar stopped. So I took out the memory card and re inserted it. This time it was quiete fast but still I couldn’t open the memory card. So I clicked again on format card and this time I did the “fast formating”, it took like 10 sec and their it was… my memory card showed up, I could open it and even my canon reconize it.

I don’t know if I got luck, if those steps has nothing to do with but it worked for and that what is important.

I wish you all good luck, I just saved up $ 300 :slight_smile: :slight_smile: :slight_smile:  

I am new to the SanDisk forum, but I have a problem similar to this thread.  I notice that the last posting was in May 2012.  Does that mean there was a solution found to an Extreme Pro card not being recognized by camera or computer?  I have lost quite a few photos on such a card, and no one seem able to recover them.  Does SanDisk respond to these posts?

So bummed on scan disk. This is third time a card has become unresponsive and they offer zero solutions their wack ass product.

Never again…

1 Like

Can I join the club?

My second 32gb 60mb/s just failed on me. Mere seconds before this I had an image opened reading straight from the card. Just as I was about to back up, I suddenly have to format it … and it is said San Disk is the most reliable???

As another post stated earlier, I am not impressed that so many of us are having problems with SanDisk cards.  Is anyone from SanDisk noticing these reports?  Is the company prepared to respond or help in any way?

Yeah I got one too the ultra mobile  (from my other post) from It never worked out of the package. I tried another sandisk from the local Wal Mart today (the only big local store) and it also has the same problems. I returned it as defective after I got no further than my car in the parking lot. Since Sandisk seems slow to respond  I will  return the Amazon.Com purchase though the vendor. 

I exchanged it for a Wintec brand card at Wal  Mart and it worked better than stated specs for a lower price. I think the time for me to trust the Sandisk brand is over.

Hi folks,

Just discovered this thread too…   this just happened to me at the weekend also. Thankfully  not a lot of data lost.

I will try the suggestions here, but wanted to know if it doesn’t work, are the cards knackered?  i.e… Completely useless, and we need to fork out more for new cards?

If so, any suggestions on brands - seems to me if SanDisk aren’t willing to address the issues, I am not prepared to give them any more of my hard earned cash.


If defective, SanDisk will replace the cards if under warranty.

I want to get the photos off my card, you can’t replace my 1 week of holiday photos

I endured a very painful experience for my Ultra 8G CF cards in the past few months too. As a heavy user of my Canon 7D, I owned more than 10 pcs of the Sandisk CF cards including Extreme and Ultra series. Each shot activity I will use around 7 pcs or more of them usually. For the concerns to lose all the photos for any single physical failure in a card, I tried not to use any memory cards with size larger than 8GB.  My photo-taking operation is very simple, only one camera but two Lens; no CF cards change unless its space used up; and only one PC with windows 7 and an USB 3.0 card reader for photos download, that all. The photo taking is always no issues at all, but the download is quite unreliable. More than five times in 2013, one of the cards among the 7 pcs which I used cannot be detected or read from my PC after downloading around one-thirds of photos. However the remaining CF cards are readable even after the faulty card case.  This faulty card is end-up with a return for new replacement because I cannot reformat it or work with my camera afterward. Just wonder what’s the root cause of the issues and how can I do if that’s my fault.


First: Im from Norway, and my english are awful! Then: Why are you taking your card out of the camera, instead of using the cabel who followed the camera? I had a EOS 50D, using Kingston 600x cards, and using cabel to transfer picture over to my computer. After that I always formatt my cards in the camera, and I have had no problems with my cards. The only problems I have had was when I tried 600x cards from Trancend, who never manage to transfer picture directly from camera to the computer. Canon said the problem had to be the compability between the card and the camera. Why I ask if you tried using the cabel for transferring data, is that Im planning to buy one or two cards from SanDisc, but I didn`t like what I saw on this pages. Maybe I after all should stay with my cards from Kingston, and be happy with that?

Just got a new Extreme 32 San Disk.  Camera (G15 Canon) recognizes card.  Shot video and stills and iphoto doesn’t recognize the thing.  It recognizes my old 2 gb Kingston just fine but not this thing.  Insert the card in reader, plug it into usb, zip, nothing, nada.  Luckily, what I shot were tests but I did format the card with the same result.  

Replying to myself but here it is.  Got a new reader, a Case Logic 55 in 1 reader/writer.  The Extreme San Disk works with this, for me.  Iphoto recognized the card through this reader but not the old jump drive I have been using.  Downloaded images fine.