Copying DVDs to Fuze and SMC errors

I used to just be able to pop a DVD into my computer and rip the video using DVD Decrypter. This hasnt been working with newer DVDs for some reason. It won’t get past 0% before it gives me a logical device error. I cant put my OWNED (that I bought and payed for at a Best Buy) on my Fuze for my personal use. I have tried multiple computers and multiple DVDs. Hancock and WALL-E both are sold with digital copy softwarer or whatever but I didnt pay the extra for that considering I could (used to be able to) just copy it from the DVD. I have tried multiple DVDs, DVD Rippers, Computers, nothing works except my older DVDs. I just ripped Underworld to put on my Fuze. That worked fine. Now I am having trouble with SMC. I also used to be able to put the *.vob file right in SMC and it would convert it away, but now it just doesnt start converting it and tells me the file failed without a reason. It even started doing this with every video. Once again I tried multiple computers, but had no success. Please help!