"Connecting" forever, it seems.

Well, if the message subject didn’t already explain it, here’s what’s goin’ on.

My Sansa Express (1GB) is stuck in a everlasting state of “Connecting”, or atleast it seems that way. I’m sure the barrteries would soon run out, but I’m not really willing to wait that long. This problem first occured a few weeks ago, when I put somem usic onto my Sansa and then - in a hurry - turned off my computer without removing the player from the back of the computer. I’m assuming that’s the reason why it’s frozen in the “connecting” state, as if it were connected to my computer still… although it’s sitting on my desk as I type this, plugged into nothing. After a few minutes of countless efforts to reset the device, I hit it a few times out of anger and for some reason (must have hit some buttons) I’m not sure of, it turned off and was fine up until now. Now the problem has returned and the player seems to not get out of the “connecting” state no matter what I do. I’ve tried holding the power for 15-30 seconds, to even 10 minutes. I’ve tried select and the volume up (+), and I pretty much ruined my Volume up (+) somehow doing so.

Anyways, I’d appreciate some help on this, because it’s really starting to tick me off. :angry:

Thanks… :cry:

If one of the buttons has a problem, you might want to give SanDisk a call about it.  Other than that, have you tried plugging it into your computer, and if so, does anything (at all) show up in Device Manager?

I’m having the same problem. The instructions say to “Click on the MTP Player icon” before disconnecting the Sansa Express, but I can’t find any such icon on my desktop. Does anyone know where this icon might be or what I need to do to get it to show up?

More information from the ridiculous manual.  You simply need to click the USB device icon in the system tray just like you would for any usb drive.  It is not an icon on the desktop.

ok…if it’s stuck on Connected screen…all you need is hard reset it…here is how…press the vol (+) and the square button at the same time and it should reset your device and correct the problem.

god bless u thnx so much for the solution.:smiley: