Connect battery not charging

I’ve had my Connect plugged into my laptop for hours and I see that the blue LED on the power button is on but everytime I try to power it on, I get a “low Batt Charging” message. I’ve tried plugging into into different USB ports on my pc but it still doesn’t seem to be charging. Anybody else ever had this problem?

If the unit is charging, the blue light should be blinking slowly, if it is steady, it thinks the batt is fully charged.  Some USB portsdon’t have enough power capacity to charge batteries on USB devices.  Did you try charging the unit with the included USB wall charger?  Even with a USB port that has adequate capacity, the wall charger will fully charge the Connect much faster.

I have had it occasionally give me the “low batt” message, even when it was fully charged.   I held down the power switch for 30 seconds (it does a full shutdown and hard reset without erasing any seetings or content) and it cleared up the problem.

Well I tried holding down the power button like you said but no, I still get the same message when I release it. I will have to try and hunt down my wall charger and see if I have better luck.

Hi Thouton,

As an old PC geek, Lappys tend to have lower USB power than standard desktops. Also, if the Sys Reqs(System requirements) are not at minimum, the player wont charge either.  Best bet is to call Griffin or Macally, I found they make wall chargers for then units and I hear they charge faster too.

Thanks. Yeah I went ahead and bought another wall charger based on a couple of the responses and it worked like a charm. I with pc’s everyday but didn’t realize that USB ports didn’t put out enough power to sufficiently charge my Connect, especially since it seem to charge it ok in the past. Thanks for the suggestions everyone.