Connect App displays "Wireless stick in USB mo...." in giant red banner while streaming video

Hi all. So I haven’t used my connect drive in about a month and today I tried to stream a video and was greated with a lovely giant red banner at the top that says that the “wireless stick is in USB mo…” I assume that this should go away but it doesn’t and while trying to watch a movie it is very distracting. I have a 64gb connect using an iPhone 6s Plus. In addition I have found that some of my movies tend to stop and buffer about every 30 seconds until they eventually just stop. I have only seen this happen on video files that are around 1.5GB and larger. If need be I can post about this in another thread but 2 birds 1 stone. video files are .mp4

So for the red banner part is this just an app issue or is there something wrong with my drive that it thinks it is stuck in usb mode?

With the video streaming is there a size limit or is there a cache/buffer issue within the app?

Thanks for the help

app version 1.0.31(1131)

firmware 4.1.0(2050)

connect the stick to the computer and see if it will establish an MSC connection. Once it does eject it properly and try it with the app. See if the USB connection issue persists. if it does try reloading the FW. If the issue still occurs after that it may need to be replaced. 

For the videos. What is the bitrate of the videos? The WS can only stream at about 6Mb/s for a single stream. If you do 2 steams for example each could only do 3Mb/s. If your videos bitrate exceeds what the WS can do the video will buffer/stutter. Videos from GoPro for example are too high of a bitrate to stream from this device. If this is the case with your videos that will need to be converted to a lower bitrate. 


I’ll try reinstalling the FW and check the bitrate of my movies. I looked at one and all I saw was a “Total Bitrate” that was 1587kbps at a total file size of 1.57GB I have no idea what that means but I will try to figure it out.

Thanks Dr Lucky I’ll write back as soon as I try the FW reload

So I reinstalled the FW which so far seems to have fixed the Red Banner issue. I will have to go through all of my video files and make sure that the bitrates are well below the 6mbps. I am assuming that the total bitrate that itunes or other programs give me is a close enough representation of the actual bitrate so as previously noted I had a file that said it had a total bitrate of 1587kbps so using the standard 1024k oer 1m this would equate to 1.55mbps. Hopefully this is right and if they are larger than the 6mbps then I will try to use something like Handbrake and reduce that. (Hopefully!)

Thanks again for the help!

If you have any other pointers I would love to hear them. I am still sadened that Apple has chosen to remove the drm decoding in Safari thusly removing the ability to stream protected movies from the flashdrive. :frowning:

Update: So I just pulled one of the videos that I know was a problem one and the Video data rate is only 1476kbps with a total bitrate of 1985kbps at 23 frames/second this is only streaming to one device (iPhone 6s Plus 128gb) and it still studders/buffers a lot. With this said am I looking at the bitrate conversion to mb the wring way or is there something wrong with the streaming speed of my device? I have an older wireless flashdrive that I am going to transfer this same file to and see if it plays ok. I do not have high hopes because I have had similar issues with other video files on this drive also and I had assumed that the file sizes were too large at nearly 2GB.

might as well be no explination at all

even though im a geek I have no clue what a MSC or a FS is

and after googling the acronym I still havent got a clue wether to 

I have a MSC connection.

we have a saying for pastors that works for geeks and gurus

that they are so heavenly minded they are no earthly good

works for mechanics and engineers too

Mass Storage Class (MSC) • Media Transfer Protocol (MTP) Windows systems support both MSC and MTP mode. Mac systems only support MSC mode.

this is total jibberish to us sandisk noobs. 

I have ejected this thing properly 30 times (annoying) and I got one time it hooked

up my android (nexus 6=marshmallow ) and my  hp15 (win 8.1)

then as I selected photos to transfer the laptop went to sleep and I lost eveything

and I got the red band of death “Wireless stick in USB Mode”

I tried downloading the firmware update into the root of the stick and that did nothing

so now there are two simple problems that should have been vetted before product 


#1 inner operability between windows 8.1 and scandisk connect

 a. testing firmware up grade flashing (i suspect it is wonkey across platforms)

 b. user control in windows off the innerweb not in a website hypertext that leads to a desert

          of information. we geeks loath talking to pimple faced know nothings that look at a monitor

           and get perplexed as we geeks fail from appoplexy talking to them.

#2 it just dosent work out of the box and that is not a proggygrammer error

      that is a marketing COO veeep that realy dosent have a grasp of what

      minimun it takes to  stand up to the bar, -----Thats yanking the bar down and saying

      “Hey limbo Anyone”!!!

this should have worked, im not a code-er but I could have done it better

yes it would  have taken time and cost alot more money.

and the repair is not even working

good thing you only burned me for 20 bucks, I would have seethered if it had been 35

the retail price at best buy, im thinking about taking it back to walmart, this is 2

12 packs of 211 steelies for me. you think sandisk would guard the name a little better

I know I would

I’ll try reinstalling the FW and check the bitrate of my movies @hotmail login