Computer doesn't detect Sansa Clip 2gb although saying 'connected'

I’ve inherited an old Sansa Clip 2 GB from my father, so therefore don’t have any of the software that originally comes with the player. However, whenever I plug it into my computer, the device doesn’t come up anywhere.

I’ve tried downloading drivers but they’re always the wrong ones or tell me that I need to move the file into the device’s files, which I obviously can’t, as it isn’t showing up. The player always comes up with the screen saying “connected” when I plug it in, but it doesn’t show anywhere.

What can I do? I really want to put some music onto the device, because at the moment all I can do is play radio (there’s no music because I can’t put any on).

Thank you!

Which “old” Sansa Clip do you have?

Is it the one with the scroll wheel on the left (original Clip) or the one with the squarish button pad (Clip +) on the right?

You might have better luck connecting by holding the left side of the scroll wheel or |<< on the button pad _ while _ you are plugging it into your computer. Continue holding the button until it is recognized. This forces MSC mode, which lets your computer see the device as any other mass storage unit, like a flash drive.

Btw, there isn’t any old software. If you need to update the firmware, that’s posted here on the forum, but you need to determine which player you have first. And I believe in the case of the original Clip, there are 2 different firmwares available depending on the hardware version. We can help you with that, but let’s see if you can get it connected first. :wink:


Thanks for answering so quickly. My Sansa is definitely the original Clip with the scroll wheel (but it doesn’t scroll, like an iPod, it’s just four buttons in a circular shape with one in the middle. It’s likely this is obvious, I’m sorry, but the picture is a little unclear).

I’ve tried everything - all modes under settings, trying to force MSC mode, force restarting it, etc. It still doesn’t come up in File Explorer. 

I have Windows 10, so that may also be adding to the problem? 

Under system info, the version says ‘VO2.01.16A’, if that’s any help with the firmware.

Here’s a picture of it, even though I’ve already described it.


Thanks again!

That is what is called a “Clip V2”.  You don’t need any software to mount it in Windows 10, so its surprising that it doesn’t show up in MSC mode.  If you set to MSC mode, does it appear as a USB device on the right side of the task bar or in the device manager?  

You could also try downloading a new copy of the Clip V2 firmware, copying it to the player, and then unplugging it.  That may unscrew up the firmware if something has gone wrong.