Clip + won't respond to any instructions

Whilst trying to change my clip+ to non European settings to increase volume I inadvertently changed to a language which I cannot read or understand.  I have followed links to change language settings and couldn’t get anything to happen.  I have used the updated both manually and automatically but nothing happens.  I have tried the suggestions from Sansa about changing language  and  updating the player and although it seems that the information is getting from my PC to my player nothing happens.

I have tried doing a reset and again nothing happens.

Does anyone have any ideas what I can do next.

Have you tried reapplying the latest firmware, manually?  See the firmware upgrade sticky thread at the top of this forum.


Thanks for the reply, yes I’ve tried that but the clip+ just won’t accept anything at all.

Did you try the instructions here?


Yes I did.  I’ve tried following all the links from the main website and I’ve followed as many links as I could find from the forum

How about this?

Thanks for your help. I’ve tried that so many times I’ve lost count.  The player will not respond to any instructions at all - from the settings menu I just get three options which I have tried in lots of different combinations but still nothing happens.  I’ve even tried to do a factory rest but that doesn’t work either.

Hmmm . . . must be something a bit more serious going on here. Have you tried formatting it? This will erase all your user-added content, but it may clear its throat from whatever chicken bone it seems to be choking on.

Hello, I just want to know how to reapply the latest firmware.

@mikecorleone90 wrote:

Hello, I just want to know how to reapply the latest firmware.


Please cease and desist! Or you could find yourself