clip + won't play thru usb car connection

I just bought a clip + to play in a car I just got.  THe car has a USB connector which allows the radio to contol the player.  I loaded songs, all mp.3’s, onto the 8 gb player and attempted to play through the car.  It plays for a few seconds then stops and seemingly freezes.  The song title does show up on the radio but after a few seconds it appears to be stuck and nothing happens and the controls to change songs don’t work, like totally frozen. .  The player keeps alternatiing between saying ‘reading’ and ‘writing’.  This is my first mp3 player so I have no clue.  Could it be that 8 gb is too big?  The player is about 80% full

What is the USB mode on the Clip (under its Settings) set at?  You might try to change the setting to the other USB mode.

I tried changing the USB setting.  That didn’t help.  One setting was not recognized at all.  I also tried playing it through the aux connection with a cable out of the headphone jack.  That did work although it’s not controlled by the car radio.  The problem with that arrangement is that d doesn’t play loud enough even with the clip volume on high and the aux volume at full blast.  Here’s the funny part. To load the MP3s into the Clip I converted some WMA files to mp3 and used a sansa cruzer flash drive to hold the mp3’s before sending them to the clip.  What someone suggested and it worked, I just put the flashdrive itself into the car usb port and that works. But it’s a 4gig flashdrive.  Now I just bought an 8 gig flashdrive and am loading all the music, same as is on the clip +.  I’ll see if that works.  If it doesn’t I think then the problem is the car usb can only handle 4 gigs at a time.  I"ll test this out shortly

the 8 gig flashdrive works fine on it’s own.  who knew