Sansa Clip won't play through car's USB

I recently bought a new Sansa clip to replace one that died.  WHen I go to hook it p to my cat stereo through the USB port the stereo gives me a message that there are “no media files”; this was never a problem with my old Sansa which worked great through the car stereo.  Any suggestings?

If your player set to MSC mode? And are the files loaded on it transferred in that mode? If not, you’ll have to delete them all, change the USB mode setting and re-transfer them.

Thanks I’ll give it a try.  Right now the USB mode under the system settings is set to “auto detect”

@jhan1959 wrote:

Thanks I’ll give it a try.  Right now the USB mode under the system settings is set to “auto detect”

Yuck–which means that the USB mode can fluctuate between MSC and MTP USB modes, leading to a confusion in your files.  Best to set to MSC mode (or MTP mode) and keep it there.

But the simple USB connection in the car probably wants MSC.  

Try setting it to MSC, and see if your computer sees music there. Your computer can only see one mode at a time. If the music is invisible in MSC, go back to MTP and connect to the computer. Move the music back to the computer (or delete from the Sansa  if you have copies on the computer already) and send it back via  MSC–or just one album if you want to experiment first.

MSC is the same connection any flash drive uses–it just sees the unit as storage. MTP is for synching other stuff via Windows Media Player.  I’d expect the car wants MSC. 

@jhan1959 wrote:

Right now the USB mode under the system settings is set to "auto detect"

Or as it’s lovingly [sarcasm] referred to around here . . . “Auto DEFECT”. :laughing:

  

Black-Rectangle wrote:

But the simple USB connection in the car probably wants MSC.  

 

MSC is the same connection any flash drive uses–it just sees the unit as storage. MTP is for synching other stuff via Windows Media Player.  I’d expect the car wants MSC. 

Thnak you all for your words of wisdom and advice.  Changing the settings and reloading the music worked!

Great to hear!   :slight_smile: