Clip Sport 'Stuck' on 'Refreshing Your Media'

When I Power In My Clip Sport It displayes ’ Refreshing Your Media’ - The Progress bar gets about the third the way across and goes no further… I have waited 24 hours - and the Progress bar has not changed.

I have done the ‘Soft Reset’ (Hold for 20secs etc) this successfuilly restarts the player and is goes back into the ‘Refreshing Your Media’ process all over again - and again stops in the same place…

I’m guessing there is a file issue - but as I am unable to get the player to connect  to the PC’s USB (Because it is stuck in Refreshing Your Media’ … ) I cannot run checkdisk etc…

I’d appreciate any help getting this what has been a wonderful device running again…

Kevin Fisher

Maybe try starting your player after ejecting your micro SD card. If this works, should be recognized by your PC using a micro USB cable that supports data transfer. 

I’m afraid I am not using a MicroSD card at all.

… Everything is in the internal (in my case 8Gb) memory.

I found several messages in this Forum with successful repairs of stuck SanDisk players. You need to be able to paste the latest firmware file (upgrade.hex) into the root directory of your Clip Sport. This will require your computer to “see” the Clip Sport via USB connection. Make sure you are using a micro USB cable that is capable of data transfer (not a simple charging cable).

Thanks - but I have already tried this.

I am using a proper USB data cable. 

… With the cable attached - when I plug it in I never get to see the Sandisk drive - The display always goes straight to ‘Refreshong your Media’

Is there a way of bypassing this so I can mount the device on my PC? and wipe/clean the Flash memory or Upgrade the firmware.

Best Wishes

Kevin Fisher

I found this suggestion by additional searching on The Google.

Press and hold down on the large power button of your Clip Sport and then connect to your PC via the USB cable.

You can stop pressing on the power button when the player screen shows a connection to your PC.

       If you still get the Refreshing Media display, then likely this idea did not help.

Thanks - You Truly are a star.


… And I thought I was good at Googling for answers!

I came up dry - hence my question here.

I had tried all sorts of key combinations - and obviously missd the ‘obvious one’

Again Thanks


Really happy to read your postive result.

Best not to use PC to format internal drive. Better to delete all your audio files from the player using WIn File Explorer.

Then see if your player starts up normally.

I try to be careful with my Clip Sport(s) with the following practices.

  1. No m4a or mp4 or mpg files (etc).

  2. No audio files with known DRM (would have to be > 10 years old).

  3. Always use the Eject command after a file management session.

Best Wishes