Clip Sport MONO only outputs to Left Earbud?

SanDisk Clip Sport just purchased!  Very cool, very light, great sound!  

Figured out so far:  

  1. DONE - Enabling Audible Books on my player - Audible Manager not Download Manager best described procedure here:

http://audible.custhelp.com/app/answers/detail/a_id/4723 finally all my Audible can be played on my Clip Sport!

  1. NEED HELP - All my currently library of Audiobooks has been converted to 32kbps/32kHz/Mono AAC for my iPod Classic 160gb, and has sufficient quality and the smallest file space (used to be Audible’s format of choice, so I started using it years ago).  Hopefully it’s easily fixable without converting my entire library to Stereo output, but with all my Mono files, the Clip Sport only outputs to my left earbud!  I have tried 3 or 4 of my other pairs of earbuds of differing mfg, but still only outputs in left ear, and the buds are pushed in very snugly.  I can’t imaging that there is a problem with my new Clip Sport, since all the audiobooks with stereo work fine in both ears, just files coded with mono.

Any help would be appreciated.  I can’t seem to find an answer on this forum, but please point me to it if you have solved this issue already.

Thanks

Here is one really simple minded idea to try:

   Buy an audio “Y” adaptor connector (aka headphone splitter cable).

   Then use two pairs of earbuds. Listen to one working bud from each pair.

It would be helpful for an audio expert to explain here how this problem was created and how to avoid.

I appreciate the suggestion… Seems a little impractical with the extra earbuds hanging loose on each ear… I’m wondering if anyone else has had this problem with MONO books… Audible “.AA” format uses MONO encoding currently, and like I mentioned all the audiobooks that I have converted myself has been encoded with MONO so that the file size is sufficiently small.  I’ve just always used an iPod, and this is my first experience with another player.  Surely the wonderful Clip Sport doesn’t play MONO in only one ear!  Stereo works fine for songs and Audible enhanced “.AAX” which is encoded with Stereo.  If I convert one of my books to Stereo at 32kbps/22.050kHz/Stereo the file size is actually a little smaller than 32kbps/32kHz/Mono - but that’s a big job in iTunes converting everything over to that format.  But it works!

Please somone tell me that there is a fix, or something in setup that I have missed, that will play mono through both ears, even if not stereo!

Ok, so I love this player, been using this for the past few weeks.  It’s nice, and just works.  Very light and can clip on a piece of my clothing while I work or hike.  I like it.  It’s got its quirks - audiobooks related - doesn’t allow viewing by author, or other parameters of an AAC file from what I see, or very weak in that area, but it plays well.

Getting back to my post on MONO output to left ear only, after a few go-rounds with SanDisk support, here is what they said - even after I sent them an AAC file converted to MONO like all my other audiobooks:

“I appreciate your continued response. I would like to inform you that, the player is designed in a way that it detects the file type if it is in mono or stereo mode and playback accordingly. If the file is found to be mono, the sound output will only be through one of the earbuds and it it is in stereo, the sound output will be through both the earbuds.  Thank you for choosing SanDisk!”

Then one last response after I suggested they just gave up on what appears to be a major issue, that they would send this to their tech folks and get back to me - eventually, I guess…

OK - down to testing - I went to Librivox just now and downloaded Autumn Fires by Robert Louis Stephenson at https://librivox.org/author/115?primary_key=115&search_category=author&search_page=1&search_form=get_results then just grabbed one very small file autumnfires_stevenson_alp_64kb.mp3 to use as a test (322k file very small).

Converted using iTunes to M4A as 32kbps/22.050kHz/Mono - ONLY plays on left ear.

I know that I can convert to stereo, but that doesn’t help my existing library, unless I re-convert everything.  Is there a utility that will just change parameters on my files in bulk selections, to stereo or some other parameter so it will play on the Clip Sport without converting the whole file to stereo?  Or why can’t the SanDisk play mono, same channel in both ears?  Does yours do the same?

Does anyone have any ideas?

Ok, so I love this player, been using this for the past few weeks.  It’s nice, and just works.  Very light and can clip on a piece of my clothing while I work or hike.  I like it.  It’s got its quirks - audiobooks related - doesn’t allow viewing by author, or other parameters of an AAC file from what I see, or very weak in that area, but it plays well.

Getting back to my post on MONO output to left ear only, after a few go-rounds with SanDisk support, here is what they said - even after I sent them an AAC file converted to MONO like all my other audiobooks:

“I appreciate your continued response. I would like to inform you that, the player is designed in a way that it detects the file type if it is in mono or stereo mode and playback accordingly. If the file is found to be mono, the sound output will only be through one of the earbuds and it it is in stereo, the sound output will be through both the earbuds.  Thank you for choosing SanDisk!”

Then one last response after I suggested they just gave up on what appears to be a major issue, that they would send this to their tech folks and get back to me - eventually, I guess…

OK - down to testing - I went to Librivox just now and downloaded Autumn Fires by Robert Louis Stephenson at https://librivox.org/author/115?primary_key=115&search_category=author&search_page=1&search_form=get_results then just grabbed one very small file autumnfires_stevenson_alp_64kb.mp3 to use as a test (322k file very small).

Converted using iTunes to M4A as 32kbps/22.050kHz/Mono - ONLY plays on left ear.

I know that I can convert to stereo, but that doesn’t help my existing library, unless I re-convert everything.  Is there a utility that will just change parameters on my files in bulk selections, to stereo or some other parameter so it will play on the Clip Sport without converting the whole file to stereo.  Or why can’t the SanDisk play mono, same channel in both ears?  Does yours do the same?

Does anyone have any ideas?

Everylyone!

I believe I have found a solution to the problem of Mono AAC (M4A) files playing in only one ear on the Clip Sport!

The problem is that AAC encoding with 32kbps/32kHz/Mono is the problem - it only plays on the left ear.  If I use MP3 encoding at 32kbps/32kHz/Mono it plays a single channel in both ears as it should!  I believe that the issue is with the Clip Sport playing AAC mono.  

Now I have a whole library of audiobooks encoded with AAC (M4A extensions) in Mono, that will only play in one ear.  I could convert my entire library of audiobooks to MP3 mono as stated above, and it plays in both ears just fine!  Problem is, it will take forever to do this.

Is there any hope that I could work with SanDisk to determine if we can take the same audiobook in AAC mono and make it play the same as the MP3 version?  Then maybe with an upgrade to the software, I may not have to recode my entire library!!!

Help and suggestions.  

One additional question, is that I have embedded artwork in all my audiobooks (Librivox) usually taking 200x200x90 pixels and these embedded artworks do not appear on the Clip Sport.  But when I take that same image and resize it with Paint.Net to 150x150x100 this shows the artwork just fine.  But, I would have to fix my entire library.   It seems that I’m within the parameters of artwork in the Clip Sport manual, so why does this not work?

Sorry for adding on questions of different natures, but I LOVE THIS CLIP SPORT!  I’ve got an iPod Classic 160gb and getting tired of it dying once in a while and having to reload it.  Plus, I have to do this with iTunes.  With the beautiful Clip Sport, I can do this with my files on an external drive, and withing Windows or drag-and-drop from iTunes.  Like MusicBee for this also.

Please assist if others have comments.

I am pleased to read that you have not given up on your Clip Sport. I enjoy using my various Clip Sports since buying my first over 2 years ago.  I have experienced a variety of problems using m4a files. I usually make the extra effort to convert my purchased m4a files to mp3 format and I like to use ID3 tag format v2.3 ISO-8859-1.

     I really doubt there are programmers / engineers affiliated with SanDisk who will be working on Firmware updates for the Clip Sport.

Here is one suggestion for you to consider:  Try out a few software programs that can automatically convert a batch of m4a files to mp3 files with your desired encoding specs.  Maybe you will get lucky and the embedded artwork will be properly displayed in the converted files?  You could test-drive a few batches of audiobooks that you want to play now, Then once you have a satisfactory process you can let your computer work unattended for 1-2 hours a day as needed?

My current favorite batch audio file converter software is “Switch Audio File Converter” by NCH Software.

     http://www.nch.com.au/switch/index.html

This software has a wide variety of settings including an option to save the converted files into the original source folder(s).

Thank you!  I was nearing that conclusion myself, and nice to know that you do that same thing.  Converting to Mono MP3 is perfect for audiobooks, with the least amount of space used, with acceptible sound.  I’ll give that software program a try… batch mode into the same directory will work very well, since I have everything in subdirectories by Author name.  

So far, I’m still having trouble with the embedded artwork, though.  I’ll experiment a bit, though even my original 200x200x96 pixels embedded cover art still isn’t showing.  I thought maybe that the MP3 format would allow some software routine on the Clip Sport to render the existing converted artwork.  I can only get this to work if I copy the existing artwork into something like Paint.net and then resize to 150x150x100.   So close to my original standard, but somehow doesn’t show.  I’m pretty sure that no batch mode will auto-resize embedded art, so I will have to do one at a time before converting to MP3.

Thanks for sticking with me!

I think the Clip Sport has some confusing requirements for the pixel size and density for artwork embedded in m4a files. 

Here is a link to a recent message stream on this Forum.

        http://forums.sandisk.com/t5/SanDisk-Clip-Sport/m4a-album-art-question/m-p/364002/highlight/true#M3764

Here is a trick you may not know for the Clip Sport.

  1. Save your desired album art file as “folder.jpg” in the subfolder with your desired podcast mp3 files. Try using a square shaped image in the range of 200-300 pixels at density between 72 and 100. (these are my personal prefs)

  2. Then make sure all the mp3 files in this subfolder do not have embedded clip art. (Very likely result from batch conversion.)

  3. The Clip Sport will display the non-embedded “folder.jpg” file while playing any “naked” mp3 files in this subfolder.

  4. You can play around with pixel dimensions and density for best results. Maybe share your results here ??

I like to use the software “IrfanView” for curating my folder.jpg and embedded jpg files.

       http://www.irfanview.com/

Thank you once again!  I have now tried the “folder.jpg” method for a series of files / tracks that make up an album.  That works great - no art in the file, but one “folder.jpg” in that folder works well.

One interesting thing that is unusual/interesting when embedding cover art in M4A or MP3 files that I have tried… I have most of my artwork at 200x200x100, and have tried 150x150x100 and even 125x125x72.  Of course, I have been using iTunes (latest version) to change the artwork, then drag and drop files from Windows 10 to a folder on my Clip Sport.  Sometimes, it seems more lately for some reason, that the cover art still does not show up on the Clip Sport.  Since that seemed odd to me, I tried Music Bee (which I have been trying out since I bought the Clip Sport) and just opened up each audiobook in edit mode, copied and immediately pasted back the artwork over itself, then it wrote it back to the folder on my hard disk.  If I used Music Bee when done to drag and drop from Music Bee to my Clip Sport, then the artwork appeared properly on the Clip Sport!  I’m beginning to think that iTunes is not following some sort of MP3 (or even M4A) rules when embedding artwork into files.  Or at least the Clip Sport is recognizing a different method possibly?  

What I’d like to know, is there a batch mode or in Music Bee, a way to select a bunch of files (audibooks) and “reorganize” the MP3 (or M4A) attributes to a “standard” way that the Clip Sport will recignize without having to copy/paste the artwork in edit mode one at a time for each of a small batch of audiobook files?  I’m not sure what “tagging” means, but is that a way to correct files pertaining to artwork and/or other fields?

Again, I really appreciate your help!

dave

Maybe it is time to start a new message topic for problems displaying Album Art with the Clip Sport ???

For now, let me say that nearly all of my Clip Sport album art display problems were due to my slavishly using iTunes for > 10 years. It works great for IOS devices. Not so much for all other players.

I think you are smart to try alternate music manager software programs.  I personally have been using “mp3tag” software to prepare my mp3 files for best tagging & display on my Clip Sport.  This software has amazing features for curating ID3 tags, cleaning up album art problems and has a wide variety of macro commands. The software also has a “m3u” playlist creator using multiple subdirectories.  SanDisk would be smart to put a link to this software in all their user manuals.

      https://www.mp3tag.de/en/

Hi. I was really disappointed that the output was mono for audible files. I have recently bought some stereo headphones that have a mono switch. I turned them mono and i get my audible in both ears. Dont  know why this is not built into the firmware! Hope this helps

I have the exact same problem and I feel the exact same way.

This should be a firmware fix.

If the audio plays in only one ear, then there should be a firmware selection (or even better - default behavior) to play the same channel in both ears.

This really bothers me a lot when I’m trying to concentrate on a book.

I should not have to buy an adapter.

From what I see, Audible uses two file formats. Low and high quality. In Windows 10 audible app downloads audiobooks in low quality by default. Sadly, in sandisk Clip Jam/Sport low quality audiobooks from audible are played in one earpiece only. We have to use high quality. How to do it?

The solution is simple:

  1. In windows 10 be sure to use audible app from windows store

  2. Be sure to go to settings (three lines in upper right corner, than settings) than downloads and check high quality option.

  3. If you have not done it already, download the audiobok and than send it to Clip Jam/Sport as you normally would. Both earpieces should produce sound. 

But what if you have already downloaded audiobook in low quality? 

You have to delete old audiobook and download it once again in high quality. 

How to do it?

  1. Delete old audiobook from HD:. In windows 10 audible app Right-click downloaded title, and choose “remove title from the device”

If you skip this step, the audible app will always send to clip sport/jam the low-quality files saved on HDD. 

You can also verify it manually. Go to three lines in upper right corner, select Settings and then Downloads and finally “Open downloads location in File Explorer”

  1. Delete old audiobook from your Clip Jam/Sport: Go to the MP3 player icon, choose location (internal memory or storage card) and click trash icon next to the choosen title

Now you can download your audiobook to Clip Jam/Sport

  1. Go to library, right click title and choose: “add to Clip Jam/Sport Storage Card” or “add to Clip Jam/Sport Internal Memory”

That’s it. Hope it helps.

2 Likes

Thanks Lukasz78000. This did the trick. Settings has moved to the gear icon lower left but otherwise I followed what you said and now I have sound out of both sides.

Now here’s something really weird that shows this is a problem with firmware.  On m4a files encoded by iTunes with Mono PLAY PERFECTLY on the ClipSport in both ears ONLY IN SLOW or FAST speed, but NOT IN NORMAL speed!!!  Now this would be fine if I could tolerated slow or fast speed.  But I find that this shows an issue that SanDisk should be able to resolve!

Comments by anyone from SanDisk support or anyone else?  Please fix this issue!

Maybe you could try to use the AAX Audio Converter to help you. It can convert AAX audio to plain audios with original quality at a fast speed. And then you can put them on your device for better listening. Just give it a try and it won’t let you down.